cancel
Showing results for 
Search instead for 
Did you mean: 

Oculis Rift S problem.

ajzzi
Honored Guest
Spoiler
Spoiler
 

Hello guys, 

before 3 days when i walked out the room i hit cable with my foot and pulled Oculus Rift S headset from the table 2 foot height and it fell down on the floor i didn’t try it or look even at it cause i didn’t think it would be a big deal, picked it up and put back on table. So yesterday i tried to play VR and my Oculus was pretty dead i’d say, opened Oculus app it says the headset isn’t plugged in, so i re-plug it in and the orange later white dot comes n i was happy tought it works, got green check marks on the app for like 1minute and it gets disconnected after that (no more green marks), sensor under that dot is lighting red like slightly but the Oculus doesn’t work. 

I tried everything, uninstalling, plugging it in different ports, going into safe mode on pc uninstalling app like everything i saw on forums and none od them worked.. So im questioning myself right now if there is any fix, i opened my headset, teared it apart and nothing seems broken/unattached or burned, everything is like clean, so what should i do, what might the problem? Is it dead? Thanks for the advices. 🙂

0 REPLIES 0
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?