Showing results for 
Search instead for 
Did you mean: 

Oculus 2 Software update required stuck

Honored Guest

Here my problem, 

We had to factory reset our device, the problem is; it’s on the screen where the two controllers need paired. Before they paired fine, now it’s not pairing the left joystick. Then we tried to pair the oculus to the mobile app bc we can’t use the controllers and this is the result. We are sitting ducks. 



Honored Guest

this happened to me too, it’s sad cuz i just got this new one from oculus cuz my last one broke and now i can’t even play it at all cuz these are my old controllers from my last one and they don’t automatically connect cuz they didn’t send ones with the headset

Community Manager
Community Manager

Hey guys!


Alrighty! It seems we may have issues coming back and leading into the app. Now we do want to bring to your attention that this is an ongoing issue that our engineers are aware if and are working on to get fixed ASAP! Don't let this get you down though. After all we are the most awesome Social Support team out there, so we're still going to try and give this our best effort! Let's have y'all perform the following:


  • Sign out of the app
  • Uninstall the app and leave sitting for 5 minutes
  • Reinstall the app and leave sitting for a couple minutes
  • Sign back into the app and try to pair again
  • Clear Bluetooth cache/computer history of the app.

As well, if that didn't prove any fruitful results, try the above steps but with the following:


  • Sign out of the headset
  • Hard reboot headset from the boot menu (hold power button and volume down for 30-40 seconds)
  • Once headset is turned back on, sign back in


If y'all have tried this and none of the above has worked, then let's get y'all in touch with some of our awesome support agents here: The agents there have a wide array of support tools at their disposal, so they may have a trick or two up their sleeves! We truly hope this gets resolved soon and that you guys can get in the VR world!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


Were you able to resolve this with your VR?  Same issue for me, I've been asked to wait for a development fix. I have been down for ten weeks with the troubleshooting and back and forth with refurbished headsets.  Beyond frustrated.  I'm hoping individuals have figured out how to get back up and running, outside of buying a new device.  Please let me know.


Any update on this?

I would like to manually update my Quest 2 to solve this, where could I download the latest version?


Cheers, Ken

Update: I manually updated my Quest to firmware v41 but it is still asking for an update like in the picture above! ;(


It works! 🙂 I manually installed this firmware here:


And suddenly the setup-process worked again! 🙂


Cheers, ken

Ken - could you please walk me through how you did this.  I've downloaded the zip file, unzipped the files, used the usb port on my pc to connect to my Oculus.  "How" did you do the manual firmware installation?


Thank you!




Hi Allison,


you don`t have to unzip it, just keep it and follow this video and at the point where you have to point to the zip file you`ll type the path to your zip!


Cheers, Can

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?