cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Air Link is not connecting

Shadow_nTTy
Explorer

Hey, i have a Quest 2, when i try to connect my pc with air link, my headset show me my pc, but when click on connect nothing happens.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Shadow_nTTy
Explorer

Ok, i dont know how, but its working now, i think its because my new motherboard got a wifi 6 and bluethoot reciver. anyway its working fine now

View solution in original post

8Blackened8
Explorer

Despite all the googling, I was only able to resolve my situation by going hard-core and searching for "Oculus" in the registry and deleting everything except for entries that had specific game titles in them. I tried every other solution listed under the sun or on the web (except for reinstalling windows… I refused to do that.) and this was the only way to make it work again! But it works! 😊

View solution in original post

65 REPLIES 65

OverPLL
Protege

What network frequency do you have? For everything to work properly, you need a 5Ghz router

I have a router 5ghz, i have connected my pc by ethernet cable, and my oculus are connected in the 5ghz 

Sholsy
Honored Guest

Repair the oculus app on the pc there is an option for it on the app and then go into the oculus and make sure software is up to date 

im still cant connect to my pc 

If the headset detects the PC, but won't pair, it's most likely connection based. While your PC may be hardwired to the router, your headset could still be having issues communicating with the PC over the network. There's an easy way to tell if your headset and PC can communicate properly. If you take the Mac address of the headset (found in the about section through your headset's settings), you can use a CMD command to scan your network for devices. 

 

Find your headset's Mac address in the CMD window, and you should see a Static/dynamic IP next to it. If you ping that IP, it will send packets to that connection. You'll either get Reply followed by the IP (which means it can communicate), or you'll get a Request timed out error (which means it cannot communicate). 

 

The network scan is "arp -a" without the quotation marks, and the ping command is just /ping {your headset's IP}. Make sure you're running CMD as an administrator before doing this, and make sure your headset is turned on an connected to the same network ssid as your PC. 

 

If you're on a network that is recognized as "public" (i.e, apartment supplied Wi-Fi, Hotel Wi-Fi, etc.), you might just need to whitelist the Mac address of your headset and PC LAN port through your router's settings. This should give the headset the correct network permissions it needs.

 

We'd be able to help out a bit better if we could get your log files through a support ticket. We'll review the logs and get back to you to help troubleshoot as quickly as we can after you send them in!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Shadow_nTTy
Explorer

Ok, i dont know how, but its working now, i think its because my new motherboard got a wifi 6 and bluethoot reciver. anyway its working fine now

stringo0
Explorer

I ran into the same issue as well, and here are the steps I tried to get it to work:
- Rename the computer's network name, and
- Restart the computer

After this I was able to connect via Quest/Air Link again.

I appreciate the suggestions from Oculus support to ping the headset - I was able to successfully ping the headset from the Desktop. This made me rule out network issues. Then I started trying random trouble shooting methods and this is what worked.

Thank you. Glad you posted your solution to the problem just in time for me to notice I'm having the problem myself. Your solution worked.

Hello,

What do you mean by renaming the computer's network name ? You mean the SSID of the Wifi network ?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?