Showing results for 
Search instead for 
Did you mean: 

Oculus App crashes Windows OS

Honored Guest

Hello, I hope this is the right place to post this.

I am having an issue with the Oculus App. When I lunch a game using Oculus Link the game (Project Cars 2) works fine but after a random amount of time (5 mins to 30 mins), the whole OS (Windows 10) crashes and PC needs to be restarted.

After some googling lot of things were pointing out that there might be an issue with the USB ports or cable itself, so I have tried Oculus Air Link and the same story. After a while whole OS crashed. About a year ago I was playing a different game (Project Cars 1) which had never before crashed, so I tried this game and the same thing happened, so I would guess this issue came up with some update of the Oculus App over time. 

I have tried the game over the Virtual Desktop and with that there were no crashes, so it only happens when the Oculus Link and App are used.

Of course, all the drivers are up to date
Windows is up to date
I have tried to uninstall completely (with data in the Users folder) the Oculus App from PC and install it again did not help.
I have monitored the temperature and load of components (gpu, cpu, ..) no spikes, no abnormal values.

Does anyone have any suggestion on what else can I try or did any of you had/have the same issue?

System info:
OS: Windows 10 professional
GPU: Radeon RX 570
CPU: i5-4690K 3.50GHz
RAM: 16gb


Community Manager
Community Manager

we were hopping on by and saw you are having difficulties with your PC app crashing. We know how finicky PCVR can be, and we understand how important it is to be able to access the wonderful world of PCVR without crashing problems. We would love to assist you on this matter all that we can!


So that we can provide accurate troubleshooting can you review the following:

  • Can you try to see if this happens with any other games besides the Project Cars line?
  • Check to see if your power setting is on the highest performance. 
  • Have you updated all of your drivers?
  • Make sure the graphics card is updated and the integrated card is disabled (only the dedicated card should be alive).
  • If PTC is active, can you turn it off to revert to a more stable version of the headset?


Here are some troubleshooting steps in the meantime:

  • Repair the Oculus PC app:
    1. Go to scroll down to Oculus Rift S and click Download software.
    2. Select Repair.
    3. Allow the repair process to run, download and install.
    4. Launch the Oculus PC app.
      • If Windows asks you if you’re sure you want to open this file, click Yes.
      • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.
      • If your antivirus software restricts the file from opening, temporarily disable your AV and continue.
      • Please remember to re-enable your antivirus software once you've completed the repair.

Let us know how this goes!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hiya hiya! We're just moseying on over to see if you are still in need of assistance. If so, please don't hesitate to let us know. Thank you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello, thanks for your reply, and sorry for the slow replies from my side, don't have so much time for playing.

Yes as mentioned in my initial request I have all the drivers and OS up to date. I have also repaired the Oculus PC app and additional when that did not help I completely purged the App from the PC and installed it again. Power settings are set also to the highest performance.

I've tried another game (Automobilista 2) which at first run did not crash (about 1h play time) but the second time I have run it it crashed in 15 minutes, so I am not sure if the first time I was lucky or the files get corrupted over time maybe. But I have tried reinstalling and repairing game files via steam and that did not help. Even though the Automobilista 2 is from different developers it actually has some shared in-game settings, so maybe it runs on the same engine, so for that reason, I will also test some other game later on.

But in the meantime would you have any other advice? Are there any logs that I could check?

Hey there! We appreciate you letting us know about the experience you are having. This is no fun, and we know it is taking time away from your time in the VR world. We want to help and make sure you do not have this issue any longer. The game you mentioned (Automobilista 2) is only available on Steam VR. Here at Meta, we only assist with our native games. Please reach out to Steam Support so they can further assist you with this issue. We do hope you find this information helpful!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

**not to mention this is almost exactly a year after this forum was posted.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?