Showing results for 
Search instead for 
Did you mean: 

Oculus DK2

Level 3
Hi there, 
I have a problem with connecting Oculus DK2 and there are 2 issues there.

At the beginning stage in the screen "Connect your headset and Oculus sensors" my computer can't connect USB and HDMI.
I found out just now that my processor does not fill requirements, but is that a reason that it can't connect or my Oculus is broken? I suppose that it should connect, but at a later stage, I should have some popup with info that my PC does not fill requirements. I'm not sure if I should trash only PC or both, PC and my Oculus 😄

Level 10
Even if it does work, there's lots of reports of dk2's no longer working on some of the latest runtimes so you'l most likely have to use a pre release legacy 0.8 driver and be confined to software released on or before that version

Level 3
Hey Mike, thanks for the answer. I've tried also 0.8 driver - forgot to mention it. There is also a problem with connecting.
I was pretty sure that my DK2 is dead, but I saw yesterday that my CPU is too weak for Oculus, so I thought this may be a problem and not broken DK2.

Level 10
So if its still not working under 0.8 then its either the hmd, your pc or your OS (win 10 might not work since it didnt exist at the time). What are you pc specs?

Level 3
PC specs
CPU - AMD FX 8320 (to weak)
RAM - 10GB
GPU - GTX 1060 6GB
USB - 3.0

I have checked Oculus HDMI cable - it's OK.

I wonder how the thing usually looks like when someone tries to run Oculus at PC that does not fill requirements. There should be some info, right? Not detecting HDMI and USB is not a common thing when PS sucks?

Volunteer Moderator
Volunteer Moderator
I ran a DK2 recently, it was still working with current (well one or two releases before current). But it was only partially working, the camera wasn't recognised so it couldn't do position tracking so it fell back on 3DOF tracking. I don't know if that was a common problem with the software or just my setup didn't like it.
Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

Hello, I am using DK2 for Sim Racing, mainly iRacing, but lately I am having some random black screens.

If I post some logs here and more details, could anybody help me understand what is happening?

I already reinstalled Oculus from scratch, but the problem is still there, today I would like to reinstall Windows from scratch and only Oculus and iRacing to see if the problem goes away.

I can post logs with the Black Screen here maybe somebody with more experience in understanding the logs can help?