Showing results for 
Search instead for 
Did you mean: 

Oculus Desktop will not launch. The headset is connected but just wont launch to the virtual pc

Level 2

It was working fine last night then pouf.. I've swapped out 3 cords the usb ports work and the same thing happens when I try air link. It shown connected just cant get to the VR pc dashboard.


Level 2

Sounds like you're having the same issue as me. Are you pc or laptop?

PC. I don't get the black screen. It just flashes and I still see the headset dash and my vr location room. I can play games on my headset. Just no launch from my link to pc desktop 

We understand how the PC desktop not working properly is a issue for the both of you. We'll like to try repairing the desktop to try and fix this. Please follow these steps to do so. 


1. Go here, scroll down to to whichever software you have downloaded and click Download software.
2. Select Repair.

  • If Windows asks you if you’re sure you want to open this file, click Yes.
  • If Windows Defender prompts Windows protected your PC, click More info and then click Run anyway.

3. Allow the repair process to run, download and install.
4. Launch the Oculus PC app.


After that, please reach back out and let us know if this helps. 

Hey again, we are just reaching back out to see if anyone is still having issues with the desktop app not launching. We want to everything we can do to get this fixed for the both of you. If you have anymore questions or concerns, please don't hesitate to reach back out!

No didn't work at all. I don't understand. No settings changes from on night to the next and this is happening. I only bought the headset to run iRacing in VR. Very disappointing. 

Thanks for reaching back out and letting us know that. We know how concerning this is for you, and we promise that we'll do all that we can to fix this for you. We'll need to take a look at your Logs to see if anything else could be causing this. To collect your Logs please do the following. 


  1. Please connect your Oculus device to your computer
  2. Find your Oculus installation directory (Generally this will be located at 'C:\Program Files\Oculus')
  3. Navigate to Support and then oculus-diagnostics
  4. Double-click OculusLogGatherer and wait for an executable to appear
  5. Select Get All Logs
  6. This will create a .zip file on your desktop. Please attach that zip file to your reply

Once you collect your Logs, please do not send them here. We don't have the necessary tools to take a look at them. 


Instead we'll like for you to go to our support website. You'll get connected with one of our amazing agents who'll take a look at them, and see what could be causing this. 

It's crazy. So I did a fresh install of Win 11. It worked 1 time after the fresh install. Then after disconnecting for a few hours it starts the issue all over just like it did before. So I buy the Virtual Desktop App and load it. The this app seems to recognize the PC and will launch iRacing via Steam VR. Which I hate doing its killing the smoothness and clarity not to mention its still not resolving the issue anyway. It almost seems like oculus software is not communicating with the windows to allow The windows Desktop to launch via wired link or wireless link. I looked at the Windows Defender Security logs and there is no mention of blocking anything nor is there any pop up asking for permission to allow the oculus app to run during my attempts to launch to the desktop. 


Hey there, @HuckFett! We definitely understand your concerns regarding these PC VR issues that are taking time out of your VR time, and we'd love to help! We'll want to review your logs, which we can't do through the forums here. Please reach out to us through the Meta Store Support site and we'll do everything we can to help get this resolved! 

Hey there! Just checking in to see if you were able to get a ticket opened for this.