Showing results for 
Search instead for 
Did you mean: 

Oculus Go Controller not working

Honored Guest

I have not used my Oculus Go in several months and went to use it for a project.  I put a new battery in the controller and charged the headset.  I turned on the headset and it was not recognizing the controller.  I tried several times to re-pair the controller but was not seeing the LED light on the controller blinking.  I held it down for several minutes.  I went through the phone app to repair as well.  Still no LED light.  The battery is brand new and I tried several from the pack.  Is the controller just dead?  I also did a factory reset on the headset just in case.



Community Manager
Community Manager

Hey there rymndkent,


We know it can be concerning when controllers won't pair, especially after the extensive and thorough troubleshooting you performed didn't work. We want to get you back into VR as quickly as possible, so we'd like to invite you to contact our support team directly!


You can open a new support ticket, then detail the troubleshooting you completed to facilitate our processes! Feel free to reach out to our support team at your leisure.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


A couple of thoughts, questions… 


Did you have a battery in the controller during the several months that it was not in use?

The Oculus Go controllers seem to have a mind of their own when put into storage even overnight without removing the battery first. To say the least, the electrical current drains very quickly! I would suspect that this could lead to battery leakage, corrosion, etc. So, if this is the case, your first step would be to physically clean the battery terminal contacts.


What button(s) exactly did you hold down for several minutes?

You need to hold down the Oculus and Back buttons on your controller until the controller LED blinks and then lights up. This should not take long. You would then continue to pair the controller via the app.


Please take a look at @MetaQuestSupport’s reply “To pair your controller:” that could be found here:

I hope this helps! Be well 🙂 

Honored Guest

Yes. I had stored it without a battery. Old habit of always removing batteries from electronics when I am done.  The buttons I pushed at the same time were indeed the back and Oculus buttons.

Honored Guest

Hi. Found this forum because after taking it out of storage for over a year the controller wouldn't turn on with a new battery and we had also stored it without a battery. I got some tweezers and scratched both battery contacts for a while and then replaced the battery and it turned on!

I had exactly the same problem and I scratched the terminals and got it to work.


Feb 2024 took the scratching battery terminal

advice and mines worked! Thanks for saving me time and energy. I almost factory rest my headset!