Showing results for 
Search instead for 
Did you mean: 

Oculus Go not pairing

Honored Guest

 I did a factory reset on my My Oculus Go - and can't get the device to startup properly anymore. It stuck at the step "connect with mobile phone APP".

I have done the following multiple times: 

  • factory reset of the go
  • restart phone/reinstall app
  • disable/enable Bluetooth
  • I tried restarting my IOS device twice.
  • The device  and  phone are fully charged

I still can't pair and set the device back up. 


Honored Guest

Hi, I have been having the same problem; meta quest app won't connect to oculus go. Reports headset not found. After reading multiple forums discussing this, I came to the conclusion that it was the newest meta quest app that was no longer capable of connecting to older go's and quest's. The current quest app version is I searched for and found older versions here: Meta Quest Old Versions APK Download (

I downloaded and installed It found the headset right away and set it up. Works now! Been an uneasy alliance with my oculus since I got it. Got worse when it changed to meta, but THEM updating the app and not ensuring it works with older headsets was crappy quality control!

Hope this helps someone else


Thanks for posting this solution. It was the only solution that worked for me. 

Though I'm intrigue with the idea of using the APK, I'm a little nervous of using a 3rd party software on my phone.  


Yeah, we are in the same boat (using iOS).
If you are using Android gadget (phone or tablet) you may using your old devices (Android 10.x or older) and Meta Quest 2.13 (or older) to pairing and recovery your bricked Oculus Go/Oculus Quest 1.
But if we are in Apple side (iPhone or iPad), we are out of luck since Apple won't let us to roll-back Meta Quest app to the older version. Some people suggested to jailbreak your iPhone so it can install the older of Oculus apps companion that still can pairing with your Oculus Go/Quest 1, but I think that's ridiculous... LOL! You will put your iPhone in serious security risk with this method. NO WAY!

Maybe it's better if Oculus (I hate to call them as Meta), release a separated version as a different Apps name in Apple Store, specially for support people who still using Oculus Go and Quest 1 so they can pairing their iPhone /iPad?

IDK, if they doing it on purpose (make the new version of Meta Quest app to abandoned/kill Go and Quest 1), then they may refuse to do that.

BTW, Last night I was successful resurrect my Oculus Go from dead with ADB/Fastboot hack (ADB shell and script to force it flipped from "sideload" mode to "device"/developer mode, and unlocked/jail-break the OS). Now my Oculus Go can be use even without phone at all! LOL!
But the disadvantage of this silly method is you can't reach out Oculus shop, you have to add your apps via sideload one by one manually and I'm loosing my environments background decoration. 

I'm still learn it (How Android's kernel and system work, as I'm not an Android system developer), I hope I will found a way to get it all back in a normal way; or the official solution from Oculus/Meta would better, since typing ADB/Fastboot syntax is very risk.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?