Showing results for 
Search instead for 
Did you mean: 

Oculus Home Net Framework issue

Level 2

Everything working fine last week, then booted up the PC and Oculus home fails to launch - no error messages just will not launch.

Then tried to launch from program files - then thought i would uninstall the program then start again. I then get an error message about needing Net Framework installed - i have this installed - then tried re-installing Net Framework - then went on to Oculus site to download/repair the Oculus Home software - but get the Framework error message when i try to launch the installer program - GRRRRR

Any help appreciated before i give up b 😞 


Community Manager
Community Manager

Hey there! Oh no! This is not the experience we want you to have. We want to make sure you are able to get back to your awesome VR device. 


We appreciate you letting us know what you have done already and want to make sure you are getting the help you need. We do want to invite you to get in contact with one of our awesome agents.


Please let them know the same steps you have taken so far and they will get you going to get this fixed! 


You can either submit a ticket, get on a live chat, and even schedule a call with them and you can do all of that here.


We appreciate your patience and hope you are having a good week!