Showing results for 
Search instead for 
Did you mean: 

Oculus Link Infinite Loading?

I've been using Quest + Link almost since release and it has been working just fine but now all of a sudden it has stopped working. It says on the oculus client that my Quest is active and ready to go. I put on the headset and enable oculus link. When I do that my screen goes black and then I'm stuck on an infinite loading screen. All I can see are the three moving dots and nothing else. I've tried reinstalling, repairing and restarting the oculus software but nothing has worked. Any help would be great

Accepted Solutions

Hey guys, got another update. I finally got it working. The solution to my problem was to reinstall my Nvidia drivers. Hope this helps

View solution in original post


Not sure if this is related or not, but I had a similar thing happen a few days ago after Link working fine since using from release.

I then noticed I had a pending Quest software update (it was the environment update as noticed these were available straight after installing) I’m not sure why or of this actually stopped Link working properly, but as soon as my Quest was updated and rebooted Link has worked again without any problems. 

Honored Guest
I also have the same or similar issue. I bought the quest about a week ago and ordered the ankor cable which many people recommend. On the oculus pc app I am getting a red error message at the top saying: "Oculus has encountered an error. Please restart your computer or contact Oculus Support." Regardless of the error message I have my device connected and active but most of the time it is either stuck on an infinite loop like yours is, or does not even show the 3 dots loading screen. I have tried disabling nvidia overlay like many people suggest. If anyone has any idea please let us know.


So update. I have reinstalled Oculus software on my computer, factory reset my oculus quest, bought a new cable and I still am having issues with infinite loading. I have no clue why any of this is happening. Any help would be greatly appreciated

Having the same problem here. Today i updated and after that it worked the first time. Now im trying to but the loading circles still there all the time

Hey guys, got another update. I finally got it working. The solution to my problem was to reinstall my Nvidia drivers. Hope this helps

I have the problem where the white dots ifinitely load aswell nothing works

Not applicable
Same issue and support basically told me they dont know what is causing this. smh

I have been struggling to get the link to work with the anker cable. I disabled my gforce experience after reading it here and all of a sudden link works like a champ.Very weird that it would be a fix for me. Some of the things i did was use a app i have for my motherboard asus b450f gaming, and friend suggested using it to see if there were any chipset drivers i may need. Sure enough i needed 3  updates. Got those installed, and still the same, i to would have the loading orbs, and a steam vr error. I was lost on what to do fora fix, even though i knew it was beta, guys were still getting it to work. Also what about the power plan your pc is on? I went in and changed the power settings for the usb. But the turning off shadow play was the trick for me..weirdgxq988dhzfo0.jpg

Honored Guest
I just got the party link 10 ft and it all works until the infinite loading screen, been looking forward to playing Boneworks since April and a response would be helpful. The second I enable link, hit deny on the access files popup, then it brings me to the three white dots.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?