cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link freezing while running apps launched from Oculus software

sentomo
Honored Guest

PC Link may suddenly freeze while running Unreal Engine apps.
This has occurred in both Uneral Engine versions 4.27 and 5.2. (Later, it also happened while running VRChat.)

I found the following forum and clean install Oculus Home, enabled the Public Test Channel, restarted Quest 2, and still no solution.

https://communityforums.atmeta.com/t5/Get-Help/Oculus-Link-freezing-when-launching-game/m-p/973859ht...

Below are my PC & Quest 2 specs.
・OS: Windows 10 Pro (Version 22H2, OS Build 19045.3208)
・CPU: AMD Ryzen 9 5900X
・GPU: NVIDIA GeForce RTX 3080
・Memory: 64GB

Oculus software version: 55.0.0.91.272
・Quest 2 version:
 ・System version: 50577570052500150
 ・Version: 55.0.0.149.713.495424200
 ・Runtime version: 55.0.0.149.713.495424008
 ・OS Version: SQ3A.220605.009.A1

PC Link uses the official Link cable.

Any other troubleshooting I can try?

8 REPLIES 8

MetaQuestSupport
Community Manager
Community Manager

Howdy there, @sentomo1 We completely understand if you're having issues connecting to the PC using the Link Cable. We know how this could impact your VR experience. Please let us know if you are only affected when using the Unreal Engine app or if you are also affected when using any other Meta apps. If you haven't already, we'll leave some suggestions below for you to consider. Which would be to ensure that the graphics settings are set to default, we'll leave the steps below.

 

  • Disable Wi-Fi on the Quest 2 Headset. 
     
  • Guide the customer through these steps to ensure their Link graphics settings are set to default:
    1. Open the Meta Quest PC app on your computer.
    2. Click Devices on the left side of the app.
    3. Click Quest and Touch.
    4. Click Graphics Preferences.
    5. Click Reset to default.
    6. Click Save and Restart

Please let us know how it goes so we can determine if any additional steps are required!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you for your reply.

I followed the steps you gave me and checked the graphics settings and they were at the recommended settings. (See attached image.)

However, I did not find a "Reset to Default" button.

GraphicsPreferences.png

 

 

 

 

 

 

 

 

 

After executing the above steps, the same problem occurred when running VR Chat.

It seems to occur not only with Unreal Engine App.

 

Thanks for getting back to us, @sentomo. If this is happening with a specific app, we'd recommend reinstalling it to see if that helps out at all. Additionally, you can try a full reinstallation of the desktop app. This gets all the cached files as well so it's a 100% fresh installation. We'll leave the steps for this below for your convenience: 
 

  • Disconnect the Rift/Link cable from the computer.
  • Disconnect your computer from the internet.
  • Backup any necessary content.
  • Reboot into Safe Mode.
  • Uninstall Oculus PC app using the Control Panel.
     
  • Delete all Oculus folders from the following folder:
  • C:\Program Files
     
  • Remove any Oculus folders from the following locations:
  • C:\Users\YourUserProfile\AppData
  • C:\Users\YourUserProfile\AppData\Local
  • C:\Users\YourUserProfile\AppData\LocalLow
  • C:\Users\YourUserProfile\AppData\Roaming
  • C:\OculusSetup-DownloadCache
     
  • Restart your computer in normal mode.
  • Reconnect your computer to the internet.
  • Install Oculus PC app again using the setup tool from our website here.
  • Reconnect the Rift/Link cable and re-test the headset.
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @sentomo. We just wanted to check in since we haven't heard back from you yet. If you'd still like help with this just let us know, we'd be glad to help out!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

After I did a fresh installation, there is no problem at the moment.
Oculus software version is now 55.0.0.91.272 (55.0.0.91.272).

I'll see how it goes for a while.

Thank you for your help.

We're glad to hear that the issue seems to be resolved. If there's ever anything else we can help out with or if you have any questions that we could answer, please feel free to let us know! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Unfortunately, the PCLink froze again while running Unreal Engine app in version 5.2.
The app is multiplayer and this problem has not occurred in other user environments.

Is there any other troubleshooting I can try or items to check?

At this point, you should check the Unreal Engine FAQ to see if there are any comparable issues. We've heard of UE having issues running Quest properly, but the procedures above usually resolve the issue on our end. Ask about your issue in their forums and see if you get a response; we'll leave the link here. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?