Showing results for 
Search instead for 
Did you mean: 

Oculus Link not working

Level 2

I am encountering an issue with Oculus Link on my Laptop. When I try to launch Oculus Link, the quest goes black and three dots of loading spin forever. This happens on Wifi or Cable.

Here are the specs:

Asus ROG Zephyrus G14, Nvidia 2060, 40Gb RAM, ryzen 9 serie 4000.

Oculus Quest 1

I have tried the following so far:

1) Reinstall Oculus software

2) Update all drivers

3) change USB cables

4) changed Wifi router

5) Checked the loadDLL registry is set to 0

6) Tried the headset on another laptop -> All good, the problem isn't the Quest

7) Tried lowering the resolution

😎Removed Virtual Desktop streamer and services

I am including the logs, there are many many errors in them ...


Community Manager
Community Manager

Hey there XquaInTheMoon. We understand you are having issues with your airlink. We see that you've already taking initiative and did some troubleshooting steps and have yet to resolve your issue. Due to the limited tools we have, we would like you to get connected to Meta store Support. We wouldn't want your information to get compromised on here. When you reach out to support, save your logs and send them over to us either though our live chat or email. If you have any questions or concerns please don't hesitate to reach out.