cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus PC app won't log in

Peabody70
Level 2

I can't login to the Oculus PC app. No matter what method I use, it just keeps telling me to open my default browser and it might take a few seconds. Then it just sits there like a lump.

8 REPLIES 8

MetaQuestSupport
Community Manager
Community Manager

Hey there! Login issues are definitely never fun, this isn't the type of experience we aim to provide. Let's get this sorted out for you! We'd like you to try out a couple troubleshooting options, let us know if these help:

You can also uninstall and reinstall the app following these steps:

  1. Disconnect the Rift/Link cable from the computer.
  2. Disconnect your computer from the internet.
  3. Backup any necessary content.
  4. You can find steps on how to do so by clicking here.
  5. Reboot into Safe Mode.
  6. Uninstall Oculus PC app using the Control Panel.
  7. Delete all Oculus folders from the following folder:
  8. C:\Program Files
  9. Remove any Oculus folders from the following locations:
  10. C:\Users\YourUserProfile\AppData, C:\Users\YourUserProfile\AppData\Local, C:\Users\YourUserProfile\AppData\LocalLow, C:\Users\YourUserProfile\AppData\Roaming, C:\OculusSetup-DownloadCache
  11. Restart your computer in normal mode.
  12. Reconnect your computer to the internet.
  13. Install Oculus PC app again using the setup tool from our website here.
  14. Reconnect the Rift/Link cable and re-test the headset.

We hope that's able to resolve your issue! Looking forward to your reply.

I'm also having the same issue, i tried the steps above without any luck. any other suggestions?

I tried the things you listed and am still not able to log in to the app on my PC. It still just sits there like a lump when I click anything but login with Oculus account. Then, when I use my email and password it tells me that's not the right combo (email or password are wrong). Can't change my password because when I try to click the change password link, it just sits there like a lump.
It's quite perturbing.

Hey there @Peabody70! We hate to see the steps provided didn't solve your issue, have you tried logging in or changing your account from another web browser or network? You may need to reach out to our support team so we can look into this further for you.

Freddynz
Level 2

Im having the exact same problem, no matter what i try the app just sits there, doesn't open a link as it's supposed to, and you cannot log in manually as it says wrong info, i've been trying everything suggested for about 4 hours now and have run out of options... pls help

An update, actually got it working, an unusual solution, deleted the app (yet again), in windows reset all app defaults (just search and it gives the option to reset everything to default), redownloaded but this time US English (instead of UK English), and at the end of the install process it actually opened the webpage correctly.... !

Thanks @Freddynz 

Followed your advice, and FINALLY got the app installed

This trick worked for me too, thanks! It should be the default answer for the many people searching for "Oculus/Meta Quest cannot ever log in."

Meta: Please fix the Oculus PC app already!