Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 1 stuck in "Download the app" screen

Level 2



I got an Oculus Quest 1 from a friend which was not powered on since one year ago.

Directly Factory reseted it so that i can pair up to it, now here comes my issue, everytime i try to pair it via the mobile app it gives me the "Unable to Connect to Your Headset" error.

I tried to connect from an Iphone 11, Iphone 13, Google Pixel 3, nothing worked, same issue everytime. In the device list in the app i have the headset but it says "Finish setup" or "Factory Reset".

If i hit Finish setup i will go to the error and no luck. Linked it to my pc and i can see the Headset there with no issue.

I have a good wifi, bluetooth on, followed every step of the pairing process over and over again, factory reseted it a bunch of times, reinstalled the app N times... still no luck. Maybe the firmware is too old ? running 231192671 firmware version. 


Community Manager
Community Manager

Hey there! That's not an experience we want to hear for our customers. We'd love to help you.


The headset may require some updates as we have done a few since you last used it. We suggest looking for updates before we pair the device with the smart phone. We also suggest making sure to un-install the Oculus app on the phone and reinstall it to make sure its on the latest version.


From there, we suggest you go to . Then you go to on your mobile or desktop app and log out. Next, you can either log in with the Facebook or Oculus account you used to set up the headset or Meta account.


Please let us know if this works for you.

Level 2

Hi! I am having the same problem. How do you update an unpaired headset?  I have not been able to get the thing to connect at all. My phone recognizes the headset and I am able to enter the code but then it won't connect. 



@Killrlwyr Heyo, that seems like quite the issue to be having. I'd love to provide a bit of insight on this. 


As for updating the headset, I do want to let it be known that this is something we've been made aware of and are working on a resolution for everyone afflicted.


With that being said, there is a couple of things that we can try found on our site here


If this doesn't work, I do recommend keeping up to date through that thread I provided. There will be updates posted as soon as we are able to provide some. 🙂