Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 won't connect to computer.

Level 0
So I got a VR game on steam and so I downloaded the Oculus app on my windows laptop. I took the issued charger cable and attached a USB C to USB 3 adapter. I plugged in the charger to the headset and the USB 3 to the computer, then I went to try and set up in the devices tab the Oculus Quest 2 in the app, and it didn't work even when connected. I then tried to connect the oculus link from inside the quest but it just kept saying "PC Not Found." I then tried to use another cable this time USB C to USB 3 with no adapters and I got the same result (both laptop and quest were on the same WiFi as well). I restarted both my computer and quest and neither have any software updates to catch up on and even though I am using a USB C to a USB 3 cable with my quest 2 it just won't connect to the computer app. How do I fix this?

Level 5
For me it's the other end that has the problem 😄 My computer doesn't recognize the quest 2... You could try putting your headset in Developer Mode. You do that through the oculus app on your phone. Otherwise I suggest you write a ticket. There are many threads around the forum with connection issues, let's just hope they fix some of it. Because there are a lot.
I5-10600kf@5Ghz, 16GB DDR3600, RTX 2070