Showing results for 
Search instead for 
Did you mean: 

Oculus Quest Store error / FitXR

Level 2


I have a strange issue. I can't access the FitXR item in the Oculus Quest Store, I get this error when trying to access

Sorry, something went wrong.

We're working on getting this fixed as soon as we can.


Within FitXR (I already have it installed on the device), I am not able to start a subscription. When I click the subscribe button for a 12 month subscription I just get the three dots indefinitely until I click the oculus button on my controller, and then it just stops without any error message and if I click the subscribe button again the same issue repeats.


I assume the error in the app itself and in the Oculus Quest Store are related.


Level 2

PS. I can access the link fine if I go into incognito mode, so it's something specific to my account not being able to access FitXR

Level 3

I can confirm this issue. But it does not only affect FitXR, but a range of apps including Blade & Sorcery, GOLF+, The Walking Dead: Saints & Sinners etc. It does not affect all apps, however.

Hey there! That's not what we want to hear for our valued customers. We'd love to see what we can do to get the apps to open.


Have you tried holding the power button on the headset for 30 seconds till it pulls up the boot menu and you select restart. You can also try to uninstall and reinstall the games to see if that works. 


We do recommend performing a factory reset as last resort. If you're worried about losing all of your purchased content we do have Cloud Backup. When Cloud Backup is enabled, Oculus backs up your device’s app data, like game progress or game settings, to the cloud. You will have to redownload the games but your account will remember your purchase history. 


Lastly we recommend reporting a bug by following theses steps: 

  1. Press oculus icon on your right Touch controller to pull up your universal menu.
  2. Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel
  3. Select Report a Problem
  4. Follow the instructions to submit your bug report

Please note that you may not get a reply from us, but their case is taken in consideration. 

That's not helpful. There's no point in restarting the headset since it's the web store (accessed from my laptop), and it has nothing to do with purchased content or cloud saves in my case, since it affects a broad range of unpurchased apps.

Hey there! If you are still having this issue, we can definitely lead you to one of our awesome agents. You can get a support ticket in and we'll get you the help you need if the steps above do not work for you.


We want to make sure you are able to get back to your awesome VR device and get be able to get your subscription.


Please click here to submit your ticket!

Level 2

I’m getting the same issue, I click on start free trial and just get the 3 dots buffering, it’s really frustrating 

Level 2

I've got exaclty the same issue as you guys above. As you said "I just get the three dots indefinitely until I click the oculus button on my controller". I've made a factory reset on device and well I was able to open browser log into my oculus account, then Ive seen on the screen "contacting your bank account..." it was successful but still I couldnt start trial....

Guys please help my wife wants this game so badly and I'm losing my mind already 🙂 

Level 3

As for the "Sorry, something went wrong" error, support suggested to me the following, which worked for me to get rid of the error (temporarily until I had several sessions again). Nonetheless, maybe it's helpful for you guys:


"If you don't mind, I'd like to just double check that any instance of your account being logged in is cleared out, so we can cross off the account being cached wrong somewhere! You should be able to navigate to '', sign in to your correct account, and navigate to 'Password and Security' listed on the left side. From there, you should see an Edit option next to 'Sessions', and opening this up and scrolling to the bottom of the list will allow you to select 'Log out of all sessions'"

Hey Ive tried your guide, but well I still see 3 dots over and over again.