Showing results for 
Search instead for 
Did you mean: 

Oculus app no longer works, also can't get it to reinstall.

Level 2
I'm not sure what is happening here. Oculus has been working fine for me for years with little problem. I'm not sure if it is the issue, but I had a windows 7 update the day before, But I did role it back and it didn't fix it. 

I first tried to start my app, and it would not. I tried to repair it, but every time it tells me I'm missing KB2670838 and KB3033929, which I am not. Obviously, I needed these when I first bought the rift. Then to find out, there is a bug that still hasn't been patched, that trips despite you having these files, oof.

Anyway, I just decided to delete everything and reinstall oculus. It still tells me the files are needed. So I used the bypass check. It bypasses the check. But still won't work. This time it installs exactly 2.02 gigs of the needed files, then goes to installation process where is fails within 15 seconds. Every time.

Yes, my firewall is disabled, as well as the virus protection.  

here is the log. 

[Debug] [7/9/2019 3:05:19 AM] Starting up OVRLibraryService v1.16.0.0.
[Debug] [7/9/2019 3:05:19 AM] Starting up.
[Warning] [7/9/2019 3:05:19 AM] IPC connection attempt failed!
[Debug] [7/9/2019 3:05:19 AM] IPC thread running; waiting for Oaf to connect.
[Debug] [7/9/2019 3:05:19 AM] App libraries for this user: [CORE_DATA]
[Debug] [7/9/2019 3:05:19 AM] OVRLibraryService starting in service mode.  Arguments: [install-package, C:\OculusSetup-DownloadCache\, C:\OculusSetup-DownloadCache\]
[Debug] [7/9/2019 3:05:19 AM] Creating NTFS transaction.
[Error] [7/9/2019 3:05:19 AM] Invalid command 'install-package'! Args: 2
[Debug] [7/9/2019 3:05:20 AM] Operation failed.  Rolling back changes.
[Error] [7/9/2019 3:05:20 AM] Exception in PerformBlockInTransaction():
System.Exception: Block returned ErrorInvalidCommand.
   at Daybreak.OVRLibraryService.Libraries.LibraryController.<>c__DisplayClass19_0.<PerformBlockInTransactionDeprecated>b__0(IntPtr transaction)
   at Daybreak.Core.TxF.PerformBlockInTransaction(Func`2 block, Nullable`1 existingTransaction)
   at Daybreak.OVRLibraryService.Libraries.LibraryController.PerformBlockInTransactionDeprecated(Func`2 block)
[Debug] [7/9/2019 3:05:20 AM] Exiting with code 18 (ErrorInvalidCommand).


Level 15
I think it may be finally time to let 7 go and grab 10 ??
A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.

Level 2
I will when I'm done with my next high end build, couple months away. Still, doesn't help me now, sadly.