cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus link cable

S.Vejgaard
Level 2

Hi there, 
Got a new PC and the Oculus Link (original) cable to my Quest 2 is not working. Its a z690 motherboard with a 3070ti GPU. It has one USBC 3.2 (gen 2) port, and it's running Windows 11. 

I've Googled a lot and have tried quite a few things: 

  • Reinstalled Oculus driver
  • Repaired Oculus installation
  • Change USB power settings and USB power plan. 
  • Change XHCI Hand-off in BIOS to Enabled
  • Beta not enabled
  • Airlink disabled.

Nothing works. 
Here's the odd part. Using a standard Apple USBC-USBC cable it's working. My PC sees the Oculus (device manager) and I can run an experience (tested with Superhot)..

Using the Oculus Link cable the Quest 2 gets power (however barely charging enough to keep the battery at level - tested at 50%), however my PC dont see the device (nothing in Device Manager or USBTreeView). Neither is Oculus PC app able to find the Quest 2. 
So what gives? The cable has worked with my old PC however I haven't been using it for the last year. 

HELP!!!

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hey S.Vejgaard! We understand how important it is to use your device in all the ways it was intended. We want to assist you with this. After looking over your information it seems like the issue is with the cable. Could you let us know if there are any kinks, bends, or breaks in the cable? 

 

We would also like to get you over to our support team so they can look into all your options. So if you go here you will be redirected to the site where you would follow the prompts based on your issue and a support specialist will reach out to you. Just provide them with a screenshot of the cable and let them know about the information we requested.