Showing results for 
Search instead for 
Did you mean: 

Oculus link suddenly not working after months of seamless PCVR gaming.

Level 3

[EDIT] : After updating to the newly released game ready drivers (496.13) through GeForce Experience, and, as gary.clark.54584 suggested, repairing the oculus client by running the setup file again, oculus link seems to be working. I'm unsure which of the two actually fixed it, or if any actually did and the fix actually came from some update the oculus developers did, but what I'm sure of is that Oculus Link is currently working for me. Will update again if new issues arise.




I'm seriously out of ideas.

I bought my Quest 2 in early July, and it's been working wonderfully since. I've been plugging it into my PC with that approved Anker USB 3.0 cable, and I've had absolutely no issues with it. Most games run perfectly, such as Blade & Sorcery, H3VR, Beat Saber, Boneworks, etc.

However, since today, oculus link just doesn't want to work at all anymore. Here's the exact chain of actions I take and the reactions from the Quest 2 :

  1. I plug the USB 3.0 cable in the Quest 2.
  2. I put the headset over my eyes and click "allow" or whatever the positive answer is at the prompt about sharing files with the computer. (I've seen tutorials saying that pressing "deny" is the preferrable option. I've however been pressing "allow" since forever with no issues, and pressing "deny" didn't do anything different either.)
  3. I get to the Oculus Home and open the quick settings menu (pressing the clock/battery/notification icon block at the far left of the task bar). I'd like to mention that prior to opening the settings, I get the usual notification over the task bar that oculus link is available in the settings.
  4. I click on the large "oculus link" block next to the Wi-Fi and Guardian ones of the same size.
  5. Screen turns black, the three dots loading loop appears to indicate that it's loading.
  6. The 3D Oculus logo appears in front of me.
  7. I see the infinite white grid-patterned link area, but only for a split second before the screen goes black again.
  8. After a short while, the 3D Oculus logo appears once more, again succeeded by a peek of the grid-pattern area, only to turn black again.
  9. Steps 7 and 8 are repeated in a loop endlessly, until I unplug the cable from my headset, thus breaking the Oculus Link connection and being sent back to the Oculus Home.

Usually, I go through steps 1 to 7 and once I'm in the white grid area, I can just select my monitor and mess around with SteamVR. The issue here is obviously that it doesn't last for more than a second before turning black again in a loop.


I feel like I tried every solution available, and yet absolutely nothing gave me the slightest inch of progress. Here's everything I've tried :


  • Rebooting computer
  • Rebooting Quest 2
  • Restoring Quest 2 to factory settings (complete reset by holding the power and volume-down buttons)
  • Reinstalling the Oculus App on my PC.
  • Updating my graphics card drivers to the latest ones through GeForce Experience.
  • Going back to a previous Graphics Card drivers version.
  • Rebooting router and modem.
  • Deleting the Quest 2 device entry on the Oculus desktop app, and adding it again.
  • Rebooting the Oculus software through the "beta" tab in the settings of the desktop app.
  • Trying Oculus Air Link instead of Oculus Link. This resulted in exactly the same results as with Oculus Link.
  • Verifying the cable connection through the Oculus desktop app in the devices tab. Results showed no issues.

I changed absolutely nothing in my computer that could've caused such an issue. The cable is in perfect condition, my headset is charged, no major updates of any software on my computer that could be even remotely related to Oculus Link has been made. I just don't know what to do at this point. I absolutely loved my previous VR sessions with my Quest 2 and would love to use it again, but this sudden Oculus Link issue makes my Steam games impossible to enjoy.

Here's my specs, in case anyone wants them :


Windows 10 x64

Intel Core i7-9700

NVIDIA GeForce GTX 1660 Ti (latest game ready drivers are 472.12)



If absolutely anyone encountered a similar issue and solved it, I would be most grateful if you would share the solution that worked for you.

Have a great day!



Accepted Solutions

UPDATE - This morning, I was continuing to troubleshoot on my own, and after I ran C:\Program Files\Oculus\OculusSetup.exe and chose the repair option, my Oculus Link it working again.


It's really odd because I've uninstalled and reinstalled the Oculus software a few times with no success, but repairing seemed to fix my issues. I hope this might help others.

View solution in original post


Level 3

Friend, I know how you are filling... I have a similar situation with the horizontal bars issue.

I just can give you one more thing to try before the completely formatting of the computer, and maybe use the Quest 2 guaranty.  


When you restarted the oculus app, in the first use of it after that, the app recognised your account automatically? If did, maybe the uninstalling was not complete. That happened to me, search how to perform a complete uninstall, and how to clean every single file related to oculus. 

I'll look into that. Thanks for the reply!

Hey there, thanks for bringing this to the community. We understand how frustrating this is to you. We'd love to help you figure this out. Try reinstalling the Link driver on your computer. You can find the installable Oculus driver file at the following path: c:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe.


If that doesn't work please submit a support ticket here with the steps you have taken for us to look into this further for you. 

I have the same issues as the OP. On Sunday, I played some VR with my daughter using Oculus Link and everything was fine. I unlinked my headset and played a few other VR games in my game room. Later in the evening I went to hook up using Oculus Link and got the 3 dots and messages saying that Oculus isn't working correctly, my headset can't be found, and that Oculus Link stopped working. I made no changes to my computer in between Oculus Link sessions.


I've done like the OP and tried uninstalling, reinstalling, updating, updating drivers, unlinking from phone app, factory reset etc... and nothing has worked. I've had my headset for about a month and up until Sunday, everything has been great. Although I do have a Rift S that I can play just fine, I sometimes like to use my Quest 2 through OL so that I get better resolution.


I tried reinstalling the link driver, but it didn't help the issue at all.

I can locate the file, but how does it work? Is it a set-up file? I executed it and absolutely nothing happened. Regardless, I sent a support ticket, which will hopefully provide results.

That sucks man. Let's just hope this whole thing will get a fix soon. I'm suspecting it might be an issue on Facebook's side, since I'm not sure how I could've caused the slightest problem in the last days by watching youtube videos and doing school work. Furthermore, their stock did nosedive pretty hard yesterday on October 4th, although I'm not sure if there's any correlation between that and the oculus link issues sprouting up recently.

Level 2

I'm having the same issues with oculus link as well. For some reason oculus link just infinitely loads and never actually starts. I never had issues with it before now. Let me know when you find a solution cause I am stumped. 

UPDATE - This morning, I was continuing to troubleshoot on my own, and after I ran C:\Program Files\Oculus\OculusSetup.exe and chose the repair option, my Oculus Link it working again.


It's really odd because I've uninstalled and reinstalled the Oculus software a few times with no success, but repairing seemed to fix my issues. I hope this might help others.

Hi, I'm also having the same problem as before. Also, I submitted a ticket (I opted for email, not chat), but didn't get any confirmation. It just took me back to the "Contact Us" page. I didn't get an email confirmation either. Does that mean the ticket didn't go through?