Showing results for 
Search instead for 
Did you mean: 

Oculus rift not working with new PC

Level 2

Hello everyone !

I know there is a bunch of topic about this problem, I've read most of them and nothing worked, so I create another one.

My setup :
 - Laptop used in dock and supposed to be VR ready
(AMD Ryzen 7 5800H / Nvidia GeForce RTX 3060 6 Go / Windows 10 Famille 64 bits)
 - Screen used on the laptop instead of the default one
iiyama 23.8" LED - G-Master GB2470HSU-B1 Red Eagle
(1920 x 1080 pixels / 165 Hz / HDMI & DisplayPort)
- Oculus Rift (not the S)


Everything is up to date. Windows, GPU, CPU, Driver, etc
When plugged, I have audio in the Rift. The screen stay off OR on but black if a VR apps is launched.

The Oculus app detect (most of the time) properly the HDMI plugged in the HDMI port while the monitor is plugged in the USB-C port. Absolutly no problem with the controllers and sensors. But the headset's USB detect my USB 3.0 as 2.0 whatever I do.
Usually, I have 3 meters cables extensions for both USB and HDMI from UGREEN brand. I did every tests with and without those.

I'll not say much more about what I tested to avoid influencing your diagnosis.


The headset worked well with my previous laptop (Razer blade 15 late 2019)

Thanks for reading 🙏