Showing results for 
Search instead for 
Did you mean: 

Oculus software download gets stuck around 5.07GB

Level 2

I’ve tried restarting my pc redownloading the software turning off my antivirus nothing seems to work can anyone help thank you


Community Manager
Community Manager

Hi @Toxulus22, you can try clean booting windows 10 (On steps 1&3 please re-check/re-enable the Oculus software/services) and try the update again. Otherwise, please try uninstalling and reinstalling the software. If you need further support, please open a support ticket with us here so we can look into your issue. Thanks!

Hi I tried this and it worked at first it didn’t stop at the download but on the install it got an error telling me to restart my pc so I did but when I tried to install it it got stuck again

sorry bro but its not gonna work 

Level 2

It is total bull and worked for me, but kudos to this reddit user Invyl "Enabling VPN (with US location) helped me. As I understand VPN, reconnect download and download continues successfully, so I think that you don't even need to enable VPN permanently - just enable it, wait until download starts/continues, disable VPN."  Link: