cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus windows client needs a complete rework

Rangerdanger7324
Honored Guest

I'm writing this post for a recent issue I have come across but also as a wakeup call to the windows client development team. You need to rework and fix your app. Over the past couple years iv stuck with oculus, starting with a cv1 and using a quest 2 with link today, the headset itself is solid, the software in the other hand is not. It's buggy, it's slow, the UI hasn't changed a bit in 4 years. And it's really looking like you don't care about your userbase.

 

 

I'd like to address the first problem being the infinite loading screen issue I received when updating to v60 and updating my windows client, I was using an older version before with no issues, all drivers are updated, windows is running on the current version, my firewall is set up correctly and so is my antivirus, so I'd just like to squash those bugs real quick. Even with all of this in consideration, the app still bugs, I connect my headset via a link cable and I am left with 3 loading dots. 

 

 

I then think my install is corrupted and needs a reinstall, your installer took 30 minutes to download less than 100mb of data for the install. This shows me how little work and support is being put into the windows client and it's honestly disappointing, I know your whole shpeel is trying to push standalone VR but when it gets to the point I can't even use pcvr that is a sign you need to redirect your attention.

 

 

The screenshots posted below are other people having issues with this recent update so it's just not me.

Screenshot_20231210_235317_Reddit.jpg

Screenshot_20231210_234555_Reddit.jpg

 

Once again I'm going to push this as much as possible, please put more time into the windows client, and PLEASE for the love of God stop software locking the quest 2 data transfer through link cable, I have thunderbolt 4 let me use it and stop locking my speeds to base usb2/3 please, that is all. Thank you 

11 REPLIES 11

MetaQuestSupport
Community Manager
Community Manager

Hi @Rangerdanger7324! We know how stuttering and lagging issues are not ideal and how important it is for our customers to have a smooth, seamless experience when playing standalone VR. We want to help you get this resolved, and there are a few steps we would like for you to perform to resolve this issue. Can you please attempt the following if you haven't already?

 

Troubleshooting steps

  • Restart the PC.
  • Make sure GPU drivers are up to date.
  • Ensure the headset is connected to the correct GPU.
  • Launch the PC App by right-clicking on the shortcut and selecting "Run as Administrator"
  • If only happening with some apps, uninstall and re-install the problem apps.
  • Add the application to the antivirus software's whitelist.
  • Try another Windows user account with admin permissions
  • Repair Oculus Home.
  • Manually re-install Oculus Home

 

Please let us know if these troubleshooting steps were helpful. We look forward to hearing from you.

 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Arjuna-Lad
Expert Protege

I thought this was just me!!! I installed a new drive and operating system, so I had to reinstall the oculus PC app. V60 PC app and V60 quest 3. Pairs fine, connects fine, but when I launch it goes to infinite loading screen. PC app gives notification of "oculus isn't working correctly".

Same as you I checked firewall, antivirus, factory reset, everything ever mentioned on this forum, etc. I'm pretty sure it's a bug in the PC app. Virtual desktop plus steam work flawlessly.

for the last few days Meta support has done their best to be helpful with troubleshooting, but it's the usual check your router stuff. Meta please have your engineers check the broken PC oculus app.

Arjuna

Thank you for your reply and for confirming that the provided troubleshooting steps did not result in a change to the issue you are facing. We would like to provide you with additional troubleshooting steps to manually repair your Oculus Desktop app. These repair steps will help guide you on what files to look for in order to perform a more detailed repair of the app.

 

Follow these steps to manually repair your Oculus Desktop App:

 

  1. Disconnect the Rift/Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content. You can find steps on how to do so by clicking here.
  4. Reboot into Safe Mode. You can find steps on how to do so by clicking here.
  5. Uninstall the Oculus PC app using the Control Panel. You can find steps on how to do so by clicking here.
  6. Delete all Oculus folders from the following folder:C:\Program Files
  7. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Rift/Link cable and re-test the headset

Please let us know if you have any questions or concerns. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I've tried all of the troubleshooting on all of the forum articles. Still doesn't work.

Thanks,

Arjuna

We appreciate you giving all of that a go, @Arjuna-Lad! If the issue seems to be software related after the most recent V60 update, we recommend submitting a bug report through the Feedback Tool in the Oculus software. This'll help document any potential emerging issues with our software for the engineering team to look at. We also recommend leaving a report of your experience on our official V60 Release Notes thread here on the forums, for the sake of visibility!

 

The team will continue to monitor reports through reported bugs and comments, so we hope we can dial in the optimization for our software a little more soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks I'll do that.

Arjuna

Sounds like a plan! If there's ever anything else we can help out with or any questions we could give some clarity to, please don't hesitate to reach out to us. We're always here and happy to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey again, @Arjuna-Lad! We hope you're having a good day so far. We just wanted to check in with you to see if you were able to leave a bug report through the feedback tool.

 

Also, if you still need any assistance or have any further questions or concerns, please don't hesitate to get back to us whenever it's convenient for you. Have a phenomenal day!
 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for checking in and following up. I sent a bug report through the feedback tool. I hope that Meta engineers notice it and find a solution. I've seen a few similar posts on this forum with the same bug I'm experiencing. For now I'm not able to use airlink so I'm using Virtual Desktop. VD works great, but there are a few apps that only work with airlink (Quill for example).