cancel
Showing results for 
Search instead for 
Did you mean: 

OculusMirror not showing guardian

jb.051172
Honored Guest

Hi,

I have a Quest 2 and I want to stream what being shown on HMD with Quest Link (I run with normal Oculus app on Windows PC). The OculusMirror does its job whether I am in Oculus Home or any other commercial games in the store. However, when the guardian, either roomscale or stationary, appears on HMD, the guardian never shows on OculusMirror, even I specifically checked show Guardian on System Layer Visibility, I tried many different combinations on OculusMirror as well as turning on/off the developer mode, but it never works. Am I missing something?

Thanks in advance if someone can help.

5 REPLIES 5

MetaQuestSupport
Community Manager
Community Manager

Hey there, @jb.051172! We see that you are having trouble with the Oculus Mirror function on your device. We understand how this can be a hindrance when wanting to stream, and we're happy to look into this with you!

 

  • Could you please provide a video of what you are seeing so we can better understand the situation you are experiencing?
  • Could you please let us know when this started happening?

 

Please provide as much information as you can about what you are experiencing. Once we have more details, we will be able to better assist you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hiya @jb.051172! We just wanted to follow-up with you to see if you were still needing assistance with the Oculus Mirror function on your device. Feel free to reach back out to us if you happen to have any further questions or concerns as we are always happy to help! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi @MetaQuestSupport, please download the video using the link: https://we.tl/t-fksfQf88iq

As you can see from the video, OculusMirror just directly turns black when outside the guardian. The guardian just does not show up in the OculusMirror while it appears in HMD. I checked the option of showing Guardian in OculusMirror

 

This happens from the first time I tried OculusMirror. I recently also factory reset my Quest2 and it does not help.

 

Thanks for reaching out!

Hey there, @jb.051172! We appreciate you providing that information for us. We will need to look into this further through our support page. Once there, we will have more tools available to better assist you! 

 

After you follow the link,

 

  1. Click on the Software or content icon.
  2. Then click on the "Using Guardian on my Oculus headset" option.
  3. Next, select "Other Guardian issue."
  4. After that, you will have the option of reaching out to our support page via email, chat, WhatsApp, or a scheduled callback request.

 

We look forward to hearing from you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi @MetaQuestSupport, I already reached the exact support page before and they cannot solve it. The support team at the end refers me to "Oculus for developers", and that's why I am asking here.

One reason I was referred here, probably because I mentioned the link below (and see the two images right before "Changing the Window Size" to learn what suppose to happen). Also, during the email exchanges, it seems they do not have resources to try OculusMirror and I had been asked to try casting with a phone and many other things (like factory reset). I did try and a phone also does not work, although I don't plan to use a phone to cast.

https://developer.oculus.com/documentation/native/pc/dg-compositor-mirror/#image-display-options

 

Let me know if I need to provide the ticket number.

 

Thanks.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?