Showing results for 
Search instead for 
Did you mean: 

Only audio

Level 2

So I was just gonna go on my oculus like how I normally do, it was charging since yesterday and when I opened it up everything looked glitched, it was weird, so I restarted it, and when I turned it back on, it sounded normally and the controls acted just like they do normally but I could not see anything, like as if it was not even on, but there was sound, i tried opening an app up from my phone but it just said that it was already opened, I tried it with YouTubeVR and Rec Room, and obviously I was not on them, I put casting on so I could actually see what was happening, and I saw the confirm boundary thing but it was vibrating, the more I moved the crazier it got, I tried pressing the oculus button and I did it twice and the voice control popped up, just kinda vibrating with the confirm boundary, I tried opening up gorilla tag in the cast menu And it looked like it opened up in the casting, but there just little parts like static kinda showing the actual game. Keep in mind that I still can’t see in my oculus. Does anyone know what is happening and how I can fix this?


Community Manager
Community Manager

Hello there! We're sorry to hear you're having this experience with your headset. We know how concerning this must be for you, and we appreciate you bringing this to the community.


Since restarting your device did not completely fix the issue for you, please try performing a factory reset. If you need the steps to do this, you can find them in the hyperlink provided. If a factory reset does not correct this issue for you, please reach out to our support team here. One of our agents will be happy to look into your options with you. 😊👍