cancel
Showing results for 
Search instead for 
Did you mean: 

Order

yakubsinl
Level 2

I just ordered A Quest 2 for my Granddaughters Birthday.  It says unable to complete.  Why?

2 REPLIES 2

I'm afraid you haven't given any any useful information at all so there is no way to help. It's like saying "Something has happened - explain it!".

 

Did you try more than once? Does it do this every time you try? Might it have been a problem with your payment method? Have you checked with your bank in case they declined the transaction? Tried an alternative payment menthod if you have one? Could a temporary internet failure have interfered with the encrypted connection?

MetaQuestSupport
Community Manager
Community Manager

Hey there!

 

As mentioned by the previous user, we will need a bit more info to be able to pinpoint what might've caused this. We want to help so here's a few we can try to eliminate:

 

  • Have you tried more than once?
  • Does the card have sufficient funds?
  • Could there be a block from your financial institution?
  • Did your internet lose connection when attempting to complete the purchase?
  • Have you tried a different card?
  • Is this a prepaid/refillable card?

 We want to help get this fixed. We don't want to keep your granddaughter from enjoying the world of VR and becoming a member of the Oculus family.