Showing results for 
Search instead for 
Did you mean: 

PC Library entirely gone 2016 to present

Heroic Explorer


I have had this happen a few times since 2016. In 2021 it took nearly a year off and on for my Oculus library to return. That was the longest stretch without being without my PC games. 

Today I launched the Meta Quest app on PC and once again my entire library is gone. I have about 1T downloaded of applications but most of them I get entitlement check errors (same problem years ago) when launched from the folder.

Was there a recent update that messed up libraries? Library is present for Meta Quest 3/2 and gen1 but PC is entirely gone. Every title I search for in the store does not have have an option to download as well.

I am using the same PC machine and windows 10 as when I first got the Rift S. I now also have a high end PC I use with Steam which also doesn't show my library. 

Disappointed this is happening again.


EDIT: This time when I updated to the Public Test Channel and reinstall the library reappears. This must be due to a recent update if others are experiencing the same. 

EDIT: Second edit: I posted below but it appears this fix was temporary.  PC Library is gone again with both regular update and Public Beta test update selected. 


Accepted Solutions

Heroic Explorer

Thank you for the response. My apologies for keep bringing up this frustrating issue. The library returned today but the fix didn't make much sense. I simply clicked a free app in the store, installed it and sure enough the entire library returned. I am not using the beta test channel at this time but that was a previous fix as that version worked. I will remember this for next time and maybe be of use for others.

One thing I should note and maybe others have also saw this is that the mobile app also doesn't populate the library in the Rift S section. I thought that was odd behavior as it just spins. 

Problem is solved for the time being. I will go through all trouble shooting steps if it's a problem that comes up again. I have no idea why this happens sometimes for weeks if not months at a time. I saw some have had this issue on the Quest headsets as well which surprisingly I have never experienced thankfully. 


View solution in original post

Hey @shogunmn, thanks for getting back to me. No worries, it is pretty odd that this comes and goes but I'm happy to hear that solution worked out for you.

I'll go ahead and mark your comment as the solution in the meantime. If this does come up again I would definitely recommend submitting a bug report for PCVR, as well as on the Meta Quest mobile app. This way they'll go straight to the engineers with all of the information they'd require.

Sometimes it's okay to be a little Bing Chilling

View solution in original post


Honored Guest

Hi  Shogunmn. Thanks so much for the advice! I have the same problem and, with your post, i have fixed it in a minute.

No problem, glad it worked!

Heroic Explorer



Library is gone again with the "Public Beta" selected. I am not sure what the issue is. All hard drives now state 0 games installed. It's interesting as there was no updates so I am not sure why this is happening again. 

I reverted back to regular update and again library is not present. 


Replicated on two PCs and CV1, Rift s, Quest 2 and 3. No Library. Either test channel or regular. I hope I don't lose my saves from the past week when the library was populating. Opening from file location appears to mostly give entitlement errors as it isn't connecting to the app. 

Hey there, @shogunmn. We really appreciate you sharing what's been going on with the community, and we'd be glad to lend a hand in figuring this out!


We'd like to begin by asking if you've ensured your devices and drivers are up-to-date, as well as if you've already submitted a bug report. With that, we first recommend double-checking for any network connection issues and restarting your devices, if you haven't already. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi again, @shogunmn! We're following up to check in and see how things are going. We'll be happy to look into the best next steps if you're still experiencing any issues.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Temporarily it seems after enabling the test beta, back to regular update and back to test beta the library now comes back. I can't make sense of why this happens. The current "update" however will brick the library from populating if not selecting the test channel in settings. Doesn't matter how many installs, what PC used etc. This continues to be replicated as a problem. There was a major outage that impacted many PC libraries in 2021 and periodically the issue returns. Maybe it's limited now to the initial legacy users on PC. No issues with the the quest library on any model  thankfully. 

Hi there, @shogunmn. Thanks for letting us know you were able to get your library back! And we really appreciate the thorough reports you've provided. While we don't have any updates as to why this could be happening currently, we'll love any bug reports you want to send our way.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

A recent update of the PC app (Meta Quest Link) broke the offline mode for Oculus PCVR games.
Without an internet connection, installed games do not show up any more, even if marked as "Internet connection not required" in the store. Trying to launch a purchased game's executable from Windows Explorer leads to an error (Entitlement failure).
The library section only shows “Oculus Dreamdeck”, “Oculus First Steps” and “Oculus First Contact”.
Only after connecting the PC to the Internet and restarting the PC app, the installed games can be accessed again.
Meta Store Support has confirmed this broken behavior, and suggested to me to open an ideas forum discussion "to bring back this option". You can vote for fixing the offline mode here 
The issue doesn't seem to gather much attention as of now. I understand that the "vote for ideas" system is meant to measure the popularity of community suggestions for new features, and allow the developers to focus on the most popular ones. But fixing "broken after update" basic functionalities such as the offline mode, especially since it is marketed in the store, should also have a high priority, no matter if it gains a lot of immediate attention in the forum or not.

Heroic Explorer

As of 7/5/24 the problem has returned and temporary fix to enable "beta test channel" no longer works. The PC library including new purchases has vanished. Re-install fails to fix. I did see there was an update for the link feature. When updated the library went away once Again. 

It's very frustrating as I just installed Ghost of Tabor and Breachers for PC yesterday. They aren't playable if they don't show up in the library on the app. 

Replicated identical issue on two separate PCs. One is windows 10 the newer is 11. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?