Showing results for 
Search instead for 
Did you mean: 

[PCVR]: Official Airlink not working and poor performance overall Quest 2

Honored Guest


CPU: 5950X
GPU: 6950 XT
RAM: 64GB DDR4 3600MHz
MOBO: x570 Aorus 
Windows Version: 10 pro
Airbridge/Link Cable (Official Cable and official D-LINK USB Router) brand new

USB Ports Tried: 
3.0 (BLUE), 3.1 powered ports (RED)

TLDR: Performance Is bad what are ALL the things I can try to make it where I'm close to a fresh slate without reinstalling windows? What graphics changes or tweaks can I do (AMD Specific or Oculus Debug Tool/Tray Tool) to get the performance I know my components can get?

Not sure why but my performance is terrible. I tried reinstalling the AMD Drivers, SteamVR, Oculus Link/Oculus Software as well as the Oculus Link Driver multiple Times. I have also tried multiple USB ports. 120Hz doesn't work so much, and even at 90, Blade and Sourcery performance is not that good. 

I have tried fiddling with the Oculus Tray Tool as well as the Oculus Debug tool, but it is still the same - Performance is just not as smooth, GPU usage is low (40-60% percentile)but it feels like my PC is chugging without any background programs running


Community Manager
Community Manager

Hey there! We know how critical smooth and responsive handling is for PCVR! We'd like to learn a bit more about how recently these performance issues started to occur, since you mentioned wanting to try to return things to a previous fresh slate. Have you updated your Quest Link app recently, or uninstalled and reinstalled it? If performance has changed with a recent update, that might help us determine the best place to start!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Community Manager
Community Manager

Hello again! We wanted to check back in with you, to see if you'd been able to uninstall and reinstall the Quest Link app? Please let us know if there's anything else we can help you with!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Fresh install and the Oculus Link app is up to date.

Hey @VitaminZeth! Thanks for the heads up! How is everything running now?

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I am still having connection issues. If I disconnect my headset from airlink, I can't reconnect. When it is successful, it asks me to confirm the pass code, when it's not successful, my PC is grayed out and the option to pair or launch is grayed out instead of the selectable blue colour. 


Only way I can fix it is by restarting my headset and turning off my wifi and airlink. Then renabling it. 


And on my pc, I need to restart the Oculus Link software through the Beta tab in the settings window. It's quite frustrating. It works, but connection always required me to restart something. Whether my PC or my Quest 2

Thanks for the update @VitaminZeth! We need more information so we can gain a better understanding of what's going on. Can you answer the following questions for us:


  • Has the connection ever worked smoothly before?
  • Are you using a mesh network?
  • Are you using wireless extenders?
  • Are you using the default gateway from your ISP?
  • Is there a password on your network?

We look forward to your reply!


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I am using the official D Link Airbridge adapter. And whether or not I had wifi, it has worked. I am currently using it hassle free. However, whenever I:


- accidently put the headset to sleep by clicking the power button

- have successfully connected, and played and then took a break, just turning the headset off.


- or navigate from quest link PCVR home, quit the airlink to the Quest 2 home


It just won't reconnect again unless I fully restart my PC or my headset, which has been a bit frustrating. 

Thank you for providing that information! It does look like this is an issue we are investigating that started affecting headsets somewhat recently with Air Link either outright not connecting or having the same behavior you are mentioning. In this case you can check out the thread here, which will provide some more information and you can add a report of this behavior there as well. It does have one other work around in the post marked as a solution, which even though this is still ongoing, we do not have a way to pin a post on the forums otherwise. We hope this information helps workaround the issues you are running into while our engineers look into this further. If there is anything else we can do for you, please reach back out and we will continue working with you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?