Showing results for 
Search instead for 
Did you mean: 

PTC v56+57 - Flashing white/colored pixel artifact problem (introduced around v53)

Expert Protege

I just updated to PTC v56, and as per the instructions in the recent PTC v56 Un-Megathread request by the Community Manager, I am posting this to its own thread with the PTC Tags.

I can report that there has been no perceivable change in the ongoing problem identified as the "Flashing white/colored pixel" artifacts problem (which seems to manifest mostly on the right side of the lens display in a random vertical line position, seemingly made worse by head movement). I am currently using a Unity built VR 180 immersive player (with an exoplayer plugin) for a VR180 H265 video file,  and the issue still occurs for me as before with no change or improvement since updating to v56.

I hope others will be able to report on this known problem with their experiences in Virtual Desktop, Airlink, VR Chat, rec room, Skybox and a bunch of other games it was previously identified on (and for where this issue is being reported and discussed on the dedicated app forums/discords for those  apps also).


237 REPLIES 237


Still getting white artifacts and band warping in v57. Haven't been able to reliable isolate the issue. I also get some odd ghosting in VRC, which I didn't prior to v56, regardless of my frames. I usually turn off ASW, as it's ghosting is more consistent. I had someone else mention this a while back, but I hadn't experience it. Now I do, but it is intermittent. 

(to note: the frequent pop up asking for feedback is annoying)

its **bleep**ing ridiculous that this hasn't been fixed but the meta team would rather put their focus on giving avatars legs and other features before fixing the base user experience. Btw, in addition to the pixels issue that is still a problem, when I tried recording some footage in VR with OBS, now in Quest link, a massive bottom section of my screen turns transparent white. everything inside of this bottom white section is insanely pixelated and distorted. its **bleep**ing unplayable. Im so sick of this **bleep** meta fix your **bleep**ing headsets I am so sick of this, I have officially run out of patience. Forgive my coarse language but how the hell is this not fixed by now. You guys are launching a new headset in a few months and i guarantee it will be plagued with the same bugs. I'm about to send this to ThrillSeeker or something at this point because I dont know what else to do since it seems like this problem is just being kicked down the road constantly. 

I certainly think that contacting VR Youtubers, Influencers and VR Publications about this issue is an acceptable course of action at this stage... so the consumers they reach have an awareness of the issue if they choose to buy  Meta Quest headsets or not. Those VR Influencers also likely have the know-how to easily reproduce this pixel issue, when directed in the many ways it shows up (Airlink, Virtual Desktop etc), so demonstrating it exists to them would not be a problem (assuming they haven't already encountered it). This would also be effective if it came from the App developers themselves of the many apps being affected (eg Virtual Desktop) since many of those Influencers communicate directly with those developers.

I think it's also extremely important to know if this issue is also still present on Quest 3 when it it released, as that would form a large part of their public/Youtube recommendation of the new HMD for PCVR and various standalone apps - which in turn would have a large impact on whether consumers choose to buy/upgrade the Quest 3, and the sales numbers.

It would also give the general Quest users a chance/voice to comment in the youtube comments if they are being affected as-well, as I suspect that we here are only a very small representation of a larger group that is silently suffering this issue.

 Right now there doesn't seem to be the downward pressure on Meta Engineering, nor the resources being focused, to properly fix this issue. And we know this is not an impossible task, as all was working well before the v53 update.


I still had the white artifacts and banding yesterday with v57 on my headset and v56 on the Rift app. I had to repair of the Rift app today, and after enabling PTC I got a driver update that accompanied v57. Haven't had any issues, but I only checked a few apps I knew were banding prone and some random games. It is a difficult issue to reproduce, so there is no guarantee that having both the headset and Rift app on v57 (w driver update) has resolved the issue on my device.

Will leave a future response if the issue comes back.

Edit: Another driver update for the Rift app. No artifacts and minimal banding after 6 hours of VR today. Banding occurred briefly in an app that often produces it. I do get some odd, chaotic ghosting under certain situations in VRC. It's while clubbing, where sub 30 frames is not uncommon. This is with ASW turned off. I toyed with every setting I available, switching between H264 and h265 under various bitrate conditions. 

I am using my backup CPU and motherboard, so a direct comparison is hard to determine. It seems like I am getting better performance now, being able to push my rates higher than before with less latency. Anecdotal, of course. 

Edit 2: Artifacts returned on the top portion of lenses. 

LOL I was in the mad as hell stage like you r in about 2-3 months ago. Now im in the I just dont give a **bleep** anymore stage. I will never buy another Meta product. Period. Just waiting on more reviews and comments on a few of these new headsets that are out before deciding on which to get. I really hope they get their **bleep** together for you guys but after over 4 months dealing with this issue I am done waiting.


I write this comment under all VR Youtube channels I know but 0 reactions(

"Hi, I love your content and appreciate all the work you do for the VR community! I wanted to bring to your attention a significant and ongoing issue with the Oculus Quest 2 that many users, including myself, are experiencing. There is a persistent problem with flashing white pixels or artifacts appearing on the screen, which has been ongoing for several PTC firmware versions, starting from at least v53/54 and continuing through to the latest version, v57. This issue is incredibly frustrating and affects many users, as evidenced by the large number of discussions on the official Meta forums, Virtual Desktop discord, and Reddit. Unfortunately, it seems that Meta is prioritizing new features over fixing this significant bug, and many in the community are disappointed with their response. As someone with a large platform and influence in the VR community, could you please help us bring attention to this issue? We hope that with enough pressure, Meta will prioritize a fix before the release of the Quest 3. Thank you so much for your help and keep up the great work!


Asus ROG Strix X470-F Gaming |AMD Ryzen 7 3700X | RTX 3080 12GB | G.Skill 32 GB DDR4 3200 MHz Trident Z | ATX Be Quiet! Straight Power 11 850W | Scythe Fuma 2 | SSD - ADATA M.2 512GB XPG Gammix S11 Pro PCI-Express 3.0 x4, Samsung 850 Evo 250GB, KINGSTON SA400S37120G


Hi I am still having the same problem with the pixelation in the Right Eyepiece while using Virtual Desktop. I have noticed if I try to record a video in VD the pixelation will not appear. Meta support have asked me to send them my Headset back to them to an address in Hong Kong and they will send me a refurbished one that they promise will not have this issue. My Quest 2 is in pristine condition, is kept in a hard case and only has around 100 hours of use in the 14 months I have had it. Is it worth sending my headset back to them to receive a refurbished one that may not have this issue.? I did read others sent theirs back and the new one still has the same issue.

I live in South Australia and wondered how long it would take to get my refurbished replacement sent out? Any suggestions on whether I should seek a new Headset or should I stick with mine and keep harassing them to fix the issue? They dont seem to be listening/responding to my emails where I say many others are having the same issue and supply them with links to these forums

@xxxDCxxx  an yet, in SE Australia I'm not having any major issues that do not allow me to use my Q2 or QPro.  Both with ptc v57 btw.  Again, you are best to try to work politely with meta support to try to resolve these.  Ranting about it in a public forum is not very useful imho.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro

So what are you saying? I should sent my Quest 2 back for a refurbished one? Or that I should just accept that it has pixelation in the Right Eyepiece?

If you are experiencing the issue reported here (and it sure sounds from your description that you are), then it is not a hardware problem, and the issue will not be solved by replacing the hardware. We just have to wait for a fix from Meta... or lose patience and buy a competitor's headset instead, I guess. 🙄