cancel
Showing results for 
Search instead for 
Did you mean: 

PTC v56+57 - Flashing white/colored pixel artifact problem (introduced around v53)

Dave200S
Expert Protege

I just updated to PTC v56, and as per the instructions in the recent PTC v56 Un-Megathread request by the Community Manager, I am posting this to its own thread with the PTC Tags.

I can report that there has been no perceivable change in the ongoing problem identified as the "Flashing white/colored pixel" artifacts problem (which seems to manifest mostly on the right side of the lens display in a random vertical line position, seemingly made worse by head movement). I am currently using a Unity built VR 180 immersive player (with an exoplayer plugin) for a VR180 H265 video file,  and the issue still occurs for me as before with no change or improvement since updating to v56.

I hope others will be able to report on this known problem with their experiences in Virtual Desktop, Airlink, VR Chat, rec room, Skybox and a bunch of other games it was previously identified on (and for where this issue is being reported and discussed on the dedicated app forums/discords for those  apps also).

 

372 REPLIES 372

@xxxDCxxx  I find it hard to believe that disabling mobile asw would make it worse while many like myself saw an improvement.  All I can think of is that maybe you didn’t save your ODT settings properly by restarting your oculus runtime services afterwards.  Otherwise I’m at a loss to suggest anything else except to continue to work with meta support, as painful as that may be for you.  I do feel your pain mate.  I’m just sorry there’s nothing I can do to help.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

I play alot of vrchat, a notoriously unoptimized game so my frame rate will always be below the target refresh rate 90% of the time. I don’t need their crappy ASW feature on constantly distorting my visuals. Honestly its an annoying feature to lock behind dev tools


@vaizor wrote:

I play alot of vrchat, a notoriously unoptimized game so my frame rate will always be below the target refresh rate 90% of the time. I don’t need their crappy ASW feature on constantly distorting my visuals. Honestly its an annoying feature to lock behind dev tools


As I've already mentioned you can easily turn off ASW on the fly with the keyboard command ctrl+num1 (numeric keyboard 1, not top row 1).  I find that I need to do this once in a while, even though I select/save it as off in ODT it seems to want to change once in a while back to auto.  I also find that when ASW kicks in I can get some pretty terrible wavy artifacts in some games/sims.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

Im hoping that was the case for me last night. I had flawless picture for a majority of the night and then it started happening again. I'm hoping the issue was as you said, the ASW kicking in on its own. I will test this tonight and hopefully that will be that

Dave200S
Expert Protege

While there are some reports that the latest PTC v57 is now working artifact-free for some users of Airlink, I'd like to   mention here that the problem still seems to be an issue for Virtual Desktop users (based on multiple reports from today alone in the VD discord) and also that our own immersive media app is still affected by the artifacts with little improvement.

Looking through the latest activity and comments of this Meta thread, it does appear like many are giving up on a fix and leaving the conversation... for which I cannot really blame them at this point. To highlight the continuing issue for Meta only as a Marker Point that this issue has not been resolved (at least at the system level) I've included a post from founder/developer Guy Godin of Virtual Desktop from just last week in their discord, indicating to users that it's still an issue that has to be fixed by Meta and it is still affecting everyone:

Screen Shot 2023-09-08 at 3.53.55 PM.png

Additionally I will say that popular VR Youtuber Nathie also highlighted a point on a video (uploaded today) about Meta's recent constant unstable updates breaking the functionality of the the new Omni VR Treadmill and their games... as the reason they have opted for Pico only. I think this is an example of these firmware problems beginning to creep into the VR press landscape, of which this artifact issue is likely the most prominent given the continuing number of views of now nearly 12K. This occurs at the 4:35 mark of the video:

https://youtu.be/JOpcZ6vRj5M?t=275

Cabinet_Black
Honored Guest

I've purchased a Pico 4 now and returned the Quest 2 since I mainly use it for PC.


@Cabinet_Black wrote:

I've purchased a Pico 4 now and returned the Quest 2 since I mainly use it for PC.


Great, I hope that works out well for you mate.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

Hey is the Pico 4 any good? Been lookin to maybe get one.

AS1C
Protege

I like it more)

Asus ROG Strix X470-F Gaming |AMD Ryzen 7 3700X | RTX 3080 12GB | G.Skill 32 GB DDR4 3200 MHz Trident Z | ATX Be Quiet! Straight Power 11 850W | Scythe Fuma 2 | SSD - ADATA M.2 512GB XPG Gammix S11 Pro PCI-Express 3.0 x4, Samsung 850 Evo 250GB, KINGSTON SA400S37120G

kibleznbitz
Protege

Any update on this? It's getting really annoying and sucking all the enjoyment I should be getting out of my $1000 headset. I don't see it in Airlink, but airlink is so broken that my framerate drops in half randomly. This doesn't happen at all in virtual desktop, but the rainbow artifacts are so immersion breaking.

I don't see how there have been so many releases since Meta's engineers have broken this, adding new features. How about fixing what they broke and pause on new feature development? How's that for a concept? You guys might want to think about it before you utterly destroy your brand. How long do we have to keep hearing that the engineers are still working on it? It's been 5 f-ing months.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?