cancel
Showing results for 
Search instead for 
Did you mean: 

PTC v56+57 - Flashing white/colored pixel artifact problem (introduced around v53)

Dave200S
Expert Protege

I just updated to PTC v56, and as per the instructions in the recent PTC v56 Un-Megathread request by the Community Manager, I am posting this to its own thread with the PTC Tags.

I can report that there has been no perceivable change in the ongoing problem identified as the "Flashing white/colored pixel" artifacts problem (which seems to manifest mostly on the right side of the lens display in a random vertical line position, seemingly made worse by head movement). I am currently using a Unity built VR 180 immersive player (with an exoplayer plugin) for a VR180 H265 video file,  and the issue still occurs for me as before with no change or improvement since updating to v56.

I hope others will be able to report on this known problem with their experiences in Virtual Desktop, Airlink, VR Chat, rec room, Skybox and a bunch of other games it was previously identified on (and for where this issue is being reported and discussed on the dedicated app forums/discords for those  apps also).

 

372 REPLIES 372

armax23
Protege

I have the same problem playing PCVR via Link

Ryanality
Retired Support

Thanks for posting! The team is working on this issue already from previous PTC reports, I'll make sure they know people are still experiencing this on the latest v56 build.

Help others find great discussions and answers by adding kudos and marking solutions to your questions.

pikpukpak
Protege

Having the same issue to the letter, been going on for multiple versions now. There used to also be a yellowish line which is now gone. Artifacts are still there. Very visible when playing population:one.

g0dmak3r
Protege

Same problem here. Messing with the sharpening and the slicing helps, but nothing gets rid of the artifacting. Started around the same build for me too.

vaizor
Protege

how is this still an issue. Don't bother releasing new numbered versions till you fix your broken base user experience

VRrandom.person
Explorer

I've had the same issue "right side of the lens display in a random vertical line position, seemingly made worse by head movement" since V53 update. This problem appeared from the first moment I installed V53 and used the standalone app TRIPP, as I do every day. From my own experience, the issue seems to vary in intensity, it depends on certain colours/brightness levels at the edge of the screen, as well as head movement. I mainly use the standalone app called TRIPP for meditating every day on my Quest 2, It's very distracting. It's been weeks/months since this issue first appeared, really need a fix for this as it can be extremely distracting at times.

I tried a factory reset, which is not something I've ever felt the need to do, since getting my headset on December 2020. It was a waste of time and made no difference to the problem. 

Just for context, I'm not part of the PTC and I seldom ever use my Quest 2 for PC VR, as I got fed up with Air link constantly being broken with every other update.  

A couple of Reddit posts I've found on this issue :

https://www.reddit.com/r/OculusQuest/comments/13n3wta/flickeringflashing_pixel_artifacts_when_using/

This one dating back to 11 months ago, with some posts only 4 days old:

https://www.reddit.com/r/oculus/comments/x5c9a6/oculus_quest_2_link_issue_flashing_pixel_artifacts/?...

At the time of writing this post, this Flashing Pixel Artifact issue and the "PTC v56 - Air Link\Virtual Desktop Crash\Hang during gameplay resulting in black screen" issue are by far the most viewed posts for the current PTC thread issues (with both about to cross 400 views each, far more than others)... based on the search link @Ryanality provided in the main PTC v56 Un-Megathread - which I believe is indicative of the specific PTC issues affecting the most people.

Unfortunately people are still posting significantly in the PTC v56 Un-Megathread, so I hope this issue is not over-looked as a result, and I urge anyone who has found this thread and is experiencing this same issue to also post here about it... even if only to confirm what is already known, as every person that chimes here in will be a help in letting the Meta Engineering team know what best to focus on and the faster we might be able to get a fix - I  appreciate this is always a challenge for any development team dealing with a complex OS and a significant industry-level user base (in the millions).

@VRrandom.person   you are correct that this has been going on for months now, which is somewhat disappointing given that this was all working fine before v53... but at the same time I understand that the Meta Quest OS is built upon an Android platform and not a unique OS, and as such there will likely be significant problems when the Android version is updated for security reasons in ways that Meta might not be entirely in control of (which I believe went from Android 10 to 12 recently). I'm grateful for @Ryanality keeping us in the loop about this and an upcoming fix, and I hope he will be able to provide an update soon.

 @VRrandom.person is an excellent example of someone who would, I gather,  never normally post in these forums but has been compelled to do so in order to get a fix for an issue affecting a specific health app TRIPP that is used daily. My investigation into the forums of other specific apps (such as Virtual Desktop discord etc) indicates that a great many people are being affected but because they might only use that specific app on Quest (like @VRrandom.person ) they believe it to be the fault of the app and not the OS... and are consequently complaining in the wrong place. I currently unofficially represent the AVPro forum group (which is a VR media player plugin for Unity) and I'm reporting back to the AVPro representatives there on the status of a fix since this is affecting both their business and mine. Again I urge people to add comments to this thread if they have the same issue and are waiting for a fix, as the number of comments here does not seem to reflect the number of views... nor the number of people being affected across specific app forums.

I'm grateful for the fact that the Meta Team has recognized this as a widespread issue (that affects certain apps more strongly than other) and are continuing to work on it across the PTC releases in view of the fact that the recent Android upgrade (and performance boost) has resulted in a lot of different issue for users, some more critical than others, and I sympathize with the difficult work the Meta Engineering team and the Meta Community Coordinators have to deal with - especially if the team sizes have been reduced lately due to industry factors beyond their control.

TekoRaiK
Honored Guest

Same for me, I can't believe how this issue isn't solved yet, very disgusting

armax23
Protege

When using the Link, I tried to turn off and on all options in Debug Tool, I tried all resolutions and bitrates, I tried to reset my Quest Pro, and tried both PTC and Public firmware. Nothing helped, flashing pixels are still present

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?