Showing results for 
Search instead for 
Did you mean: 

PTC v63 - DCS crashes on Link



This is a cross post from my post in the PCVR forum from 16/2/24. As reported by others, a version of the v63 PTC (at the time, an update released on 15/2/24) caused a crash to desktop when running Digital Combat Simulator. Switching off the public test channel fixed the problem.

Now that v63 is being released as stable, has this issue been addressed?

102 REPLIES 102

Meta Quest Support
Meta Quest Support

So yes, DCS has worked well on Oculus devices like the Rift, which is a designated PCVR device. Since DCS is a PCVR game that is also not fully supported by Meta Quest, it will likely run into some problems. If you were seeing problems while you were on PTC, then it likely brought those problems out. I want to reassure you that I'm not trying to give you any wrong information, as that was not my intention. My information comes from the link I provided, which states, "If you try to run DCS World inside your Oculus Quest 2, it will likely crash, in this case, disconnecting and reconnecting the cable." If the issue is only happening with this one game, then you may need to reach out to the game developer and ask that they make the game more compatible with Quest devices. 

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.

Not sure where that information comes from but there are several people using quest devices in DCS. Plenty of YouTube influencers and such have reviewed and tested the quest 3 and quest pro in DCS. I've been using my quest pro without issues in DCS with a link cable since release. It's the v63 update that introduced something which has caused it to stop functioning. 

Since the last update, I have also had a systematic crash when launching DCS from the Oculus meta link app Version I'm on a Windows 11 PC and I'm using Quest 3. The headset and app are with the latest firmware. Everything worked very well, but since the last update it has been impossible to launch DCS. DCS is launched from the Oculus interface in Quest 3 but systematically crashes when displaying the DCS home page. I have two computers with DCS and Oculus installed and the phenomenon is exactly the same. What to do ??????

It's a pity we get these kind of answers from META. The linked page from ED for DCS cleraly states: 

What VR devices does DCS World support

HP Windows Mixed Reality Headset, HP Reverb G2, Oculus Rift S, Oculus Rift CV1, Oculus Quest 2, HTC Vive Cosmos, HTC Vive Pro, HTC Vive Pro 2, Pico3, Pico4, Pimax 4K, Pimax 5K, Pimax Vision 8K, Valve Index, Samsung HMD Odyssey and others.

But the AI in META kept only the last sentence from this:

Oculus Quest 2:

  1. Start Oculus app.
  2. Plug the USB  to Oculus Quest 2.
  3. Enable Oculus link.
  4. Start DCS World with a mouse click directly from the desktop.

If you try to run DCS World inside your Oculus Quest 2, it will likely crash, in this case, disconnecting and reconnecting the cable.
There is definetely an issue to DCS caused by V63 which relates to OpenXR but META denies to recognise the issue.

I've been using Quest 2 and Quest Pro with DCS for 4 years now without issues via Link.

Such responses and reaction from META make me regret suggesting these headsets to friends for use with DCS


And in response to this:
If the issue is only happening with this one game, then you may need to reach out to the game developer and ask that they make the game more compatible with Quest devices. 
ED for the related issue wrote:
The problem has been caused by the Environment Access Check timeout for Meta Quest Link v.63 being changed

Hey there! We understand that you are having issues with launching DCS. This certainly sounds like it would be a hinderance to your VR gaming experience, so we wanted to point you in the right direction. We suggest that you reach out to the developer directly for assistance. You should be able to contact their support team by logging into their support page, located here. As they are a 3rd party developer, they should have the best tools for assisting you in getting this resolved. As always, please feel free to reach back out to us if there is anything else we can possibly assist you with!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Having the same problem, also I did already asked DCS developers and they found this is a problem with latest oculus app update.

It's not an issue with the headsets, it's an issue with your V63 update. It's been a known issue for weeks now. Why hasn't it been resolved? I see customers who have not been able to use there headsets for weeks. That is disgusting and as a huge corporation like Meta you should be doing better. We should be allowed the freedom to roll back updates if an issue is found, you should do in house testing before a beta is released. As beta testers we still have the right to a working headset. I am currently in talks with my solicitor in regards to some kind of legal action in regards to the lack of communication from you and the lack of a fix for weeks now. You were made fully aware of the issue and have done nothing to rectify it, and if you have, you've kept it a secret because low and behold. Two weeks down the line and I'm still unable to use my headset in Air Link or Link Cable as I still get Crash To Desktop at the splash screen whilst trying to load DCS World. We pay good money for your products, we tick all the relevant boxes for you to sell our information on, now fix this issue before it becomes a law suit.

Honored Guest


after update my DCS World is crashing and my VR session not starting.

How to downgrade it to v62?

The information you provided from the link is incorrect, because it is taken out of context. The same link clearly states earlier how to run DCS on a Quest 2. Quest 2 is also listed as supported. It is firmware update v63 which broke the OpenXR compatibility. The follow up posts by @diamond_25 also contain further information on the nature of the problem. This is a bug which should be reported to the development team. Can you assist with that?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?