cancel
Showing results for 
Search instead for 
Did you mean: 

PTC v63 - DCS crashes on Link

arrow11crash
Explorer

Hello, 

This is a cross post from my post in the PCVR forum from 16/2/24. As reported by others, a version of the v63 PTC (at the time, an update released on 15/2/24) caused a crash to desktop when running Digital Combat Simulator. Switching off the public test channel fixed the problem.

Now that v63 is being released as stable, has this issue been addressed?

102 REPLIES 102

UPDATE:  Meta 3 HMD was just upgraded to 64.0.0.347.368.581241021
Meta Quest Link App Version 64.0.0.359.367 (64.0.0.359.367)
This did not fix DCS Crashing
This is the DCS World 2.9 (Stable New install) shortcut target :
"C:\Program Files\Eagle Dynamics\DCS World\bin-mt\DCS.exe" --force_enable_VR --force_oculus_VR

I appreciate you sharing that. I'll pass this information on to our engineers, and I'll let you know what they say.

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.

awol87025
Honored Guest

Last update crashes DCS on load Quest PRO. $6,000 system for DCS ONLY, now won't work on VR. Had to go back to my HP Reverb, what a waste of money. Meta will not be my future HMD purchase.  Along with all the crap games and Social B.S. Jejune Apps, I knew I should not of gone with a company like Meta.  

how did you manually revert it back to V62?

 

Jdw.81
Protege

This is a re-post of one I made several pages back. The problem seems to be with the PC link application. Do what this guy says (copy his V62 files into the correct directory of the PC Link application). It is not difficult and it got me back into VR with zero issues. The PC app still shows to be V63 since the .exe is not overwritten. If you still can't get back into DCS and are forced to play 2D until this issue is fixed, you can manually edit the options.lua file in the saved games Config folder to set VR enable to false (use Notepad++).

 

This guy's solution worked for me this morning. Read the thread about stopping Oculus service. Just copy and paste his files into the existing directories mentioned. I just flew with no problem. https://www.reddit.com/r/dcsworld/comments/1bnspf6/recent_oculus_vr_bug_fix/

It's because on the latest update to 63 app and headset no longer supports open xr and they know it, just won't do anything about it.  On the app settings where it says set oculus open xr runtime...is now shaded out.  DCS flight sim is now broken, seems only Vitual Desktop and SteamVR are supported.  I think the Meta developers were recruited from the same Academy as the community managers on here, what a joke.

Jdw.81
Protege

Just to be extra clear, the you do not replace the entire folder that you download. You just copy the files in that downloaded folder into your installed oculus folder with the same name. It will ask you if you wish to overwrite the existing files. Yes.

I have the same problem. With Quest 3 and DCS 2.9. The problem is the Oculus update 63.0. Before that my Quest 3 has always worked well with DCS (I was running the DCS Beta version before). In any case, Oculus version 62.0 apparently functions with DCS. So the question is twofold or you instruct us how to return to  Oculus version 62.0 or oculus has already a new update or patch that will resolve the problem with DCS 2.9 stable usage of Quest 3. Thanks

How does one revert to old version. Can you elavorate please

Jdw.81
Protege

I can only comment on my situation. My headset is still V62 as I have automatic updates turned off on it. From what I'm hearing (no firsthand knowledge), the problem is with Oculus Link software on the PC. That was certainly the case for me and many others. Meta pushed an update of the PC software to V63 and there is no option to turn off automatic updates (short of setting up a firewall). The link I shared above has 3 folders to be downloaded. Unzip the folders and copy the included files into the corresponding folder in your Program Files - Oculus. Do not replace the existing folders. Simply copy the files in the downloaded folder into the correct folder on your PC. You MUST stop the running Oculus service before you copy the files into the correct folder. The Oculus link (PC) software will still show V63 but you should now be able to run VR in DCS. When Oculus opens back up as DCS starts (Oculus OpenXR makes this happen), the Oculus PC app should provide a good Rift Link.

If this does not work for you, I cannot provide any more detail or help. I am simply repeating what worked for many other people. The reddit link for the fix has instructions also.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?