cancel
Showing results for 
Search instead for 
Did you mean: 

Pairing bug fix/workaround.

Hi all! As a lot of you including me had experienced weeks/months of a very frustrating bug preventing people from being able to pair their headsets (including brand new headsets) with the Phone's Meta App, I have finally found a solution. At least it worked for me.... it may also work for those with the inability to pair their headsets to their controllers but I cannot comment on that. I simply couldn't pair my headset to the Meta App - this solved it.

 

Please try this:

 

1) Download "Meta Quest Developer Hub 3.0" from: https://developer.oculus.com/documentation/unity/ts-odh/?locale=en_GB

2) Install this, plug your headset into your computer using the USB C cable the headset came with etc. 

3) Start the Meta Quest Developer Hub application. Once inside, turn the headset on. Go through the steps the application advises in order to connect to the headset. They're pretty much "on screen by default". This will (at least for me) bypass the whole pairing to phone/tablet app entirely and it will just pair with the computer. 

4) After that is complete. Your headset should be ready to use. You will also see on the phone/tablet app the headset is now listed/added too.

 

Hopefully this will work for you as much as it helped me! If so, feel free to buy me a coffee 🙂 https://www.buymeacoffee.com/anderson20S

 

 

PS: I cannot believe how Meta Quest support do not know of this workaround/fix. It's their own software that managed to fix this problem. Not some random third party software that nobody has heard of... perhaps they're instructed not to tell people about this fix?? either way, it is bizarre.... and very frustrating to have spent so long trying to fix this only to find that Meta's own software fixes it in seconds. -_-

6 REPLIES 6

godilo
Level 3

Hi Noa,

I am trying to do what you say, but it gets stuck in pairing, in a different way, it appears the Serial Number, I put next, and then it thinks permanently and nothing else happens. Do you have any extra details? Thanks

Captura de pantalla 2022-11-08 001253.png

godilo
Level 3

Noa,

I change to the charging cable (not the gaming one) and showed something different, now is asking me to upgrade firmware, happened to you?

 

Captura de pantalla 2022-11-08 003501.png

benjilat
Level 3

The software sees the headset but just hangs forever when you click the blue button and it never finishes. 
What a miserable problem. 
This is also a new RMA replacement one and no success. 

Hi, It changed with other cable, now says upgrade headset firmware, do you know how and where I found it?

SebbydaPro
Level 2

This fix worked perfectly, though note I needed to factory reset the device first. 

I still can’t pair with my phone or iPad, but it appears I can do everything I need within the virtual environment despite continued prompting to use the app.