cancel
Showing results for 
Search instead for 
Did you mean: 

Pc not finding my link cable or air link

Mrmememan223
Honored Guest

I just got a PC and a link cable(it is a syntech cable) for Christmas and I have been trying to connect my PC to my Quest 2, at first I tried to connect my headset via air link, but for some reason my oculus couldn't find it, it could find my brothers PC's but not mine. I did research to try to fix it but nothing worked. So then recently I have been trying to connect my headset via link cable. But when I plug in the headset with the oculus PC app open all it says is to click on the notification to allow the USB to access my files. And when I click on it, it just extracts videos that I've taken on my oculus. I am plugging the other side into a USB 3.0 port, every thing is up to date (I think) and I've tried pretty much every thing that I could find on the internet. Can someone help me?

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hi @Mrmememan223! We know how much fun PCVR can be, so let's take a look at solutions for you to get back in the game! We'd be happy to assist with getting your setup taken care of as smoothly as possible.

 

  • Can you confirm which version you're running on your PC app?
  • Can you also confirm which software build you're running on your Quest 2?
    • You can check in Quick Settings > Settings > Software Update under the Current Version Details section. The formatting should be 59.#.#.###.###.######### or 60.#.#.###.###.#########.
  • Have you ever been able to run PCVR on your Quest 2 before?
    • Have you made any hardware or network changes between when it was working and when it started having issues?
  • Is your PC app/headset on PTC?
  • Which cable are you using to tether your headset to the PC?
    • Is it the one that came with your headset, or another cable?
  • What's your network setup like when attempting to connect via Air Link?
    • Is your PC connected to your router, modem, air bridge, or an extender?
    • Is it connected over Wi-Fi or with an Ethernet cable?
    • What frequency is your network connection at? (2,4Ghz, 5Ghz, 6Ghz, etc.)
    • How far above the ground is your access point? How far away from the headset is your access point? (in the same room, another room, etc.)
    • Is your connection set to public or private?

If your headset cannot communicate properly over your network with other devices, it's possible that your network has restrictions or limitations in place, keeping your headset from communicating effectively with other devices across the network. Also, what kind of WiFi connection are you on? We look forward to your response and hope to hear from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?