cancel
Showing results for 
Search instead for 
Did you mean: 

Population: One not available for purchase

Stormin_Gorman
Level 3

I can not purchase population on for my new Quest 2. Started Meta account and able to purchase other games but Population: One does not show up in store. If search in safari takes me to oculus store but says unavailable at the bottom where normally would be the price to purchase and link. Will this be fixed soon?  I want to return my oculus if not as this is my main reason to purchase. @MetaQuestSupport 

8 REPLIES 8

MetaQuestSupport
Community Manager
Community Manager

Hi there! We understand you are unable to download population one. No worries, let's see if we can help you with that. First, have you tried going through the app store in your headset to see if you can purchase it that way? If that doesn't work here is the link to purchase the game from our website.  

Yes I have tried in the store on headset. Does not even show up when searched! You link works to the game app but at bottom of the link where normally you click to purchase it says unavailable

Hey there! Are you using any type of VPN?

Nope. I have even tried with using my cell phone hotspot WiFi and still does not show up in store. And when click your link provided above still says unavailable. 

I’ve had the same exact issue and spoke with several reps via chat with no solution.

Thank you for getting back to us. It sounds like your headset may not be on the latest version. If the app doesn't show up at all this is likely the cause. Use these steps to make sure you're on the latest software version. 

 

We don't have all the required tools to assist further here on the forum. If the issue continues we recommend you to submit a support ticket. One of our specialists will be happy to look into more options for you! 

Reaper-USAF
Level 2

I own Population One on my Rift S. I was trying to gift Population One to my son who is 14 on his Quest 2. It says that he cannot redeem it and therefor it will not even try to send it. It also does not show up in my sons available games to buy straight from his Quest 2. Is there an age restriction on the game. The only reason I bought it for my Rift S was to play with my son on his Quest 2.

Hey Reaper-USAF! We see that you are having issues trying to gift your son the game Population One. We understand the importance of being able to share your experiences and we want to work with you to look into this more. We want to start off by mentioning that our store offers the various platforms that you can play the game on. When you gift your son the game you must switch your store option to Quest and then look up the game. The store might be automatically set to Rift since it is the one you commonly use for yourself. If this does not work we would like to get you over to private chats so we can gather some information from you and assist you further. You can send us a PM by doing the following:

 

Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.