Showing results for 
Search instead for 
Did you mean: 

Prime Video VR app not playing videos on Quest 2

Not applicable
I have just received my Quest 2 and have have been setting up the apps I have on the original Quest. Although I loaded the Prime Video VR  app and signed in, videos will not play. I receive the following message:

"Error loading information
We encountered an error loading the page. If the problem continues, sign out the Prime Video VR app, restart your device, and then sign in again.
ERROR: 4107"

I've followed the instructions, but it hasn't solved the issue, also the app still works fine on the Quest.

Could anyone please help?


Level 3
Exact same issue here

Level 3
I spoke with amazon customer services... they told me to try a few things and nothing worked except deleting the entire app and reinstalling it. I still get the error but if you hit retry 3/4 times it eventually will play the video. Give that a try. I've told them the error is VERY annoying and it needs to be looked at.

Level 3
They've passed it on to the tech dept that deals with the app and I've given them a link to this forum so they can see its not an isolated issue.

Level 15
The Amazon Prime Video app works great on all my Oculus mobile devices (Go, Q1, and Q2).  I watched a movie last night with my Q2 and it worked and looked fantastic.  It was a 2 hour movie and I never had the Q2 go to sleep like some have reported.  Maybe because I was moving my head once in a while for popcorn and my drink, lol!

Prime Video is regional so if you are having problems it's best to contact your local Amazon Prime Support for help.  Also remember that you need to register each device.  This was kind of a pita for me because it gives you a code to enter and I needed to write this down and then enter it.  Also, I believe there is a limit as to how many devices you can register and this may vary from region to region as well.  If you run out of devices you can just deregister one you may not be using much.

In any case, I hope you manage to get it working on your Q2's.  The Q2 has gotta be the best mobile movie viewer out there now imho.
i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, QPro w/Air Link, Vive Pro

Level 3

same problem here, tried everything, deleting multiple times both data and app, rebooting, diffirent login methood shuting down, allowing a day go by and try all again. and by the way, what disturbed person desided to have the login keyboard in alphabetical order in stead of qwerty 

Level 2

I have the same issue. Cant even log in so I cant use app at all. So usless app...

Level 2

Apparently this has been going on for some time!  I have tried ALL of the suggested fixes...NONE of them work.  I don't understand why they can't get his under control.  I have deleted the data and uninstalled the app at least 5 times.  I have checked the box for data storage permissions when installed.  I have hit retry numerous times.  Nothing works!!!!   VERY frustrating!


I’m thinking they aren’t too fussed about the app and are not trying to fix it

same issue here and also issue 4162 tried to download a purchased film - got to the end of the download and said download failed sign in out delete all that same crap error 4162