cancel
Showing results for 
Search instead for 
Did you mean: 

Pro Controller update broke tracking

Jumpiestpants04
Explorer

Today i received a pro controller update that broke tracking, I have already contacted support and went through the steps so no support rely is needed on this topic. 1.38.x controller update wont let controllers track, I have a set of controllers on the old version 1.36.0 and they work fine, so i already created a suggestion to give users the ability to downgrade any firmware, as this will let users use there device if a bad update bug appears like this. Like i mention in that suggestion even apple lets us downgrade software, and there a strict company.

1 ACCEPTED SOLUTION

Accepted Solutions

I also today found out another odd solution on the main branch i just changed wifi networks and they started to track and stayed tracking even after reboot and connecting to the old network.

View solution in original post

26 REPLIES 26

Hauk.Eye
Honored Guest

I've got the same problem... Having to restart the headset and/or controllers multiple times when tracking is suddenly lost without warning is truly ridiculous, especially considering it happens every 10 min, that is if you're lucky enough to have them track that long.... It's ridiculous that Meta still hasn't learned not to be releasing untested broken updates like this.

honestly on this update I only got both controllers to track one time, restarted my headset and controllers repaired them and one will randomly start working but not both. Only one time they did as soon as I reboot never worked again. I did find my own solution temporarily I have a headset with a broken face tracker, so I used those controllers on old firmware just need to keep the headset WiFi off won’t let controllers update which can be a big deal to some. Also I found a glitch my old headset works normal it’s firmware is on v62 and when I connected the controllers same tracking issue. But oddly I get an update controller message this update(or should I say downgrade) took forever. Here it downgraded the firmware and look they work as expected. Honestly I’m tired of these bad updates to just 3 weeks ago there was the overheating glitch again every 15 minutes they will shut off, I had to use the public test channel to get a update because of that. 

jaggedgargoyle
Honored Guest

I'm having the same problem on my Pro controllers after the update. Crazy to be dealing with this after buying such an expensive headset. 

Hey all! Without your controllers, your VR experience would not be as fun! We want to look into this for you, so if you could send us a direct message (DM), that would be great!Please select our name to get to our profile page, or click here: https://metaque.st/CommunitySupport. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey all! We just wanted to know if you all still needed help! Let us know if you have any questions! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honestly there is most likely no help until the next controller update, as I have already determined it is a controller update that caused the issue. Like I mentioned somehow honestly Surprised myself it did it. When I connect my controllers to a headset out of date it downgraded them and they worked. As I reinstalled the update to see the problem come back.

Hey there @Jumpiestpants04! What troubleshooting steps have you already tried? 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Elgsdyr
Honored Guest

Hello folks

I have/had the same problem with v65. Solution at the bottom (yay). Here's the detailed description of my problems, that I sent to the support (which made them think wrongfully that I needed replacement controllers):

  1. If I put on the HMD, and the LEDs turn on (solid white). When activating the controller (A/X):
    1. Sometimes they appear and work as intended in VR
    2. Sometimes the handtracking hands disappear, but nothing else appear instead. The Meta/System button works (open/close menu, reset view) but no tracking and no other button works. When opening the Shutdown menu, a tracked white dot appears, but it's tracked in reverse of my controller movement, that is, when I move the controller up, the white dot moves down, etc. Same with Left/right.
      • LED stays on
    3. Sometimes nothing changes and it stays in handtracking mode. The Meta/System button does not work.
      • LED stays on
  2. If I put on the HMD, and the LEDs stay off.
    • When activating the controller (A/X) the LEDs start blinking white. Otherwise same as with 1.3 - stays in handtracking mode and no buttons or tracking work.
  • I've experienced once or twice that rebooting the controllers made them work, but otherwise this hasn't worked.
  • Rebooting the HMD makes them work in most cases, if I make sure to keep them awake during boot, but sometimes I have to reboot the HMD one more time.
  • I tried resetting the controllers once more but that didn't yield any improvement or change.
  • Controller firmware: 1.38.1
  • Pre v65 the controllers worked perfectly as described at the top.
 
Solution:
As I saw others describe their issues being fixed with v66 from the public test channel, I decided to give it a shot (controller firmware is now 1.39.2). The controllers now work 90% of the times I pick up the HMD. The remaining 10% I get the weird issue described in point 1.2 above. Luckily, all I have to do is to let HMD + controllers go to sleep and activate them again, and everything works.
 
How to activate updates from the public test channel:
  1. Open the Meta app on your phone
  2. Go to the page of your Quest 3 headset
  3. Open the Headset Settings at the bottom of the page -> Advanced Settings
  4. Activate the toggle at Public Test Channel and let the headset and controller update

Thank you so much @Elgsdyr for finding a solution to the controllers! We are so happy that customers like you come in and save the day! We hope that you have a wonderful rest of your day! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?