Showing results for 
Search instead for 
Did you mean: 

Pro controllers won't connect to quest 3 after v65 update


Ugh.. this just started happening.  I assume it is a problem that came with one of the updates to the headset?


After putting my Quest 3 headset to sleep after playing, the pro controllers no longer automatically connect when it wakes up.

The only thing that fixes it is restarted the headset.

It just so happens that I have two pairs of pro controllers.  This problem occurs with both.

Restarting controllers doesn't fix it.

Factory reset of controllers doesn't fix it.

Turning headset on/off doesn't fix it.

Have to restart the dumb headset every time I play now. 😞

198 REPLIES 198

- Pinning this for visibility and to provide update.

Hello again everyone, I just got an update from the team saying the engineers were testing it on v66 and it was successful to not have the disconnecting issue. I know some of you are still on v65, but once v66 is at 100% rolled out, I hope your able to use the controllers again! 😊

In case you need it, here are the steps to factory reset your controllers only:

  • Right Controller: Hold A and Oculus buttons until the LED begins flashing red/white.
    Left Controller: Hold X and Menu buttons until the LED begins flashing red/white.
  • Release the buttons immediately after the LED begins blinking red/white.
  • Perform a manual pairing and check if controller LED would flash blue and white to signal pairing state.
  • Once paired, controllers may take a while to update and stay unresponsive until they finish, and LED would be purple during the update.


Update 6/29/2024:

After further investigation from the team, it looks like they were unable to reproduce the issue on the latest V66 build. The team is suggesting those still experiencing issues to please contact @MetaQuestSupport through private messages to have your warranty options looked into. If that is the case, I also ask that you please submit a bug report as detailed as you can with what you are experiencing. That way the team can keep track of further reports on this issue throughout the future.


“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.


I'm having this same issue: Quest Pro controllers losing tracking ONLY in Beat Saber. Partway through a song the saber (controller) will disappear -- sometimes both disappear. And then the song fails, and after a few more seconds the sabers are back (i.e. the controllers regain tracking), but it's too late because the song already failed.


I have NO shiny surfaces anywhere and the room is well lit. Note: I never had any of these issues with my Valve Index. I'm playing in the exact same spot I've been playing on my Valve Index for the past four (4) years, and never had trouble in Beat Saber or any other game. (I only switched to my Quest 2 with Quest Pro controllers because the Quest controllers are significantly lighter, and I'm an older player concerned about joint health.)

This issue is extremely frustrating, as today the controllers BOTH lost tracking 3/4 of the way through a song I was about to Full Combo for the very first time.

Losing tracking during Beat Saber is a different, unrelated, issue.

This issue described here is consistently happening ONLY when the headset goes to sleep for even a brief moment, and what you would experience is that you would (for example) finish the song, take the Quest off (or even just lift it up enough) to take a drink or something similar that puts the Quest into Sleep Mode for a second (because you lifted it up enough that the "occupancy sensor" between the lenses thought you took it all the way off - or maybe you DID take it off for a second...) 

...and when you put it back on, 10 seconds or 10 minutes or 10 hours later...

The controllers don't reconnect. The buttons work (you can recenter with the Meta button on the right controller), but they don't track anymore until you manually cycle power on the Quest with the power button, pointing at "RESTART" and using the volume button to confirm the restart of the Quest headset. 

A few people have said they have to restart multiple times. It's worked for me on the first try every time.

It's still related to the Pro Controllers, at least from personal experience.

The issue is wwith the WiFi in the headset; tracking is done via WiFi but button presses are done via Bluetooth.

I've even managed to record it randomly happening, thanks to the record option still working, (hold down the Quest logo and hold the right trigger for a second to start and stop).

I could dream forever, and never stop. I could think of life and beauty, the stars that fade in the sky. The hearts of lovers, the dreams of dreamers.

I don't know that it's necessarily a wifi issue in the headset... 
Didn't a couple of people mention that it started happening after they updated their controllers (after updating to V65)

I know that's my case, for sure. I got a firmware update on the controllers, and that was the first I remember having to restart the headset...

Expert Protege

During the issues, I've tried even factory restoring my Quest 3 a couple of times and it had issues doing initial setup, which are done over WiFi, (and can be done with any controllers or even hand/headset gestures to an extent).

Standard Touch Plus controllers are also unaffected as they operate via BlueTooth.

There have also been some reports of Quest Air Link acting up for people, which I believe also relies on WiFi.

Some people have also said that their headsets sometimes lose connection to.

It's also been reported on the Quest 2 and Quest Pro, outside of the controllers themselves, the only common factors are that it's the V65 firmware and it's only affecting WiFi.

I haven't experienced that last statement nor can I confirm the one before it, but it seems the WiFi is more likely to be the culprit, especially since the button presses themselves still function even when the tracking isn't working.

Apparently reports are saying that V66 stable resolves it, though V66 PTC was getting mixed results.

I could dream forever, and never stop. I could think of life and beauty, the stars that fade in the sky. The hearts of lovers, the dreams of dreamers.

This reminded me to check my headset again, and YAY V66 is installing right now. 1.2GB.

I'll come back and edit this post with my Trip Report here in a bit...


V66 SOLVED this for me with no further action.

Steps to Reproduce.

1. Accept and install V66
2. (optional) Let your headset sit on your racing rig next to your desk while you gaze longingly at it during meeting after meeting for work... 😄 )
3. Pick up the headset and put it on without picking up the controllers, and while having them out of sight, but within reach.
4. Verify that you don't have hand tracking on by waving your hands around.
5. Turn and pick up the controllers. They will not be recognized AT FIRST (per my Trip Report, YMMV). 
6. Wave your hands around like you have been after a restart on V65, (don't just turn your wrists, move your shoulders and elbows, too) and watch as the Ghost Hands come into view and snap onto your real hands!
7. Set the controllers down and verify you don't have hand tracking (out of thoroughness)
8. Touch the Headset power button to put it to sleep.
9. Count to your favorite number.
10. Touch the headset power button to wake it up.
11. Verify that the headset Tracking Dot is visible (optional - use it to open a menu or whatever)
12. Pick up the controllers again. My RH controller snapped right to my right hand. My LH controller had about an 8" offset "vertical" (from the back of my hand) and a 2" offset "back" (toward my wrist) for about 20 seconds as I did the "calibration dance" and it kept that same offset...but then after 20s it also snapped to my hand correctly.
13. This is the floor from Being John Malkovich
14. Set the controllers down again and put the headset to sleep again this time by taking it off and waiting while you count to your favorite number.
15. Wake the headset up by putting it back on. Observe that there are no hands (as expected)
16. Turn and pick up the controllers. They *may* have Ghost Hands on them waiting for you. They *may* snap right to your hands *after* you pick them up.
17. Use them for a bit, then use the "put the headset to sleep" test again.
18. After the third Put The Headset To Sleep test, the controllers are now snapping to my hands instantly - it seems that the prediction software needed a few minutes of data to get fully back up to speed with correct predictions.

This is SOLVED for me (for the moment)

Late Night Edit...
Checked it again a couple more times this evening. The LH Controller takes a second to get fully synced up spatially (literally 3-10 seconds when first picking up the controller after the Headset and Controllers BOTH have been sleeping). Before that it's off by a few milimeters - maybe up to a half inch at first.
But after that? 
Smooth sailing.


As of yesterday, my Quest 3 doesn't seem to have got V66 yet.

One thing that you might want to try is to desync and resync the controllers with the app too, just incase it needs to update anything, (it also forces them to check for any updates to the controllers too).

I could dream forever, and never stop. I could think of life and beauty, the stars that fade in the sky. The hearts of lovers, the dreams of dreamers.


Hi, I'm back with feedback.

Yesterday v66 was available for me, I installed it and updated the meta pro touch controllers as well.

At first they worked right away after the update, I turn everything off (off like powered down off) and set them aside.  Later that night I picked them up, turned evertying on and the same issue appeared.  Also, If for whatever reason i dont move them for like Idk,, 5..10..20 seconds? they go to sleep and tracking is lost, and it was "harder" for the tracking to come back, and very slow, like a minute, between they wake up and reconnect (all while sleeping and waking up the headset as well). I've submited a bug report again. 

Here are the updated details

  • Which headset you're using: Quest 3
  • Are you enrolled in the PTC? NO
  • Software Version Meta Quest Mobile App:
  • Software Version Meta Quest Headset:
  • Any other workarounds?  Use the power button on the headset to make it sleep and turn on a few (2~5) times, and they eventually (connect and) start tracking again)
  • Confirmation of Bug Report submitted.  Yes.

Thank you.

Thank you for that update information @SIMCGA. Can you let me know if you tried factory resetting the controllers yet? I'm hoping that works out any kinks the controller may still be having after the update. 

“There are only four rules you need to remember: make the plan, execute the plan, expect the plan to go off the rails, throw away the plan.” -Leonard Snart.
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?