Showing results for 
Search instead for 
Did you mean: 

Problem with quest link video loading

Level 3


Two days ago I started having problem with the quest link, prior to that everything was working fine, when I try to start a VR video from desktop chrome the Headset is stuck on loading screen, if I remove the headset I can see that the video start in chrome tab and not in the oculus quest headset.

I've tried to turn off and on again the oculus, reset the factory settings, updating the quest, windows and chrome but with no succes.

What else could I try?  



Community Manager
Community Manager

Hiya there @Foxburning! We understand you are having issues with your Quest link. No worries, we can do our best to help you get issue situated. So we can get a better understanding of what is is causing this issue, could you please provide us with the following: 


  • Do you receive any error messages? If so, can you share a screenshot of the error message
  • Have you checked to see if you meet the PC requirements
  • Does your headset work when not connected to a PC? 
  • Are you connecting your USB cable to a USB 3.0 port ? 
  • What type of cables are you using ? 
  • How many other USB devices do you have connected to your PC?
  • Ensure your graphics drivers are up to date. If not, please make sure you update them. 

Once you get this information back to us we can assist you further. We look forward to hearing back from you. 


►No, i do not receive any error

►I meet all the pc requirements

►My headset does work when not connected to the pc

►Yes, I'm usin a 3.0 USB port

►I'm using a USB A to USB C 3.0 for Quest 2

►Keyboard, mouse, Headset and gamepad

►The GPU driver are up to date, even the the windows one and the oculus too

Everything was working fine until 2-3 week ago.

See attached the screenshot of what I see from the VR headset when I try to start a quest link browser VR video.OculusScreenshot1675592887.jpegOculusScreenshot1675849776.jpeg

Thanks for reaching back out and providing all of that information. We'll like to try manually uninstalling and reinstalling the desktop to get this fixed for you. 


  1. Disconnect the Quest/Link cable from the computer.
  2. Disconnect your computer from the internet.
  3. Backup any necessary content.
  4. Uninstall Oculus PC app using the Control Panel.
  5. Delete all Oculus folders from the following folder:
    • C:\Program Files
  6. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
  7. Restart your computer in normal mode.
  8. Reconnect your computer to the internet.
  9. Install Oculus PC app again using the setup tool from our website here.
  10. Reconnect the Quest/Link cable and re-test the headset.

After you do that, please reach back out and let us know how that helped. 

Hey we are just reaching back out to see if you are still having issues. We want to do all that we can to get this fixed for you. We look forward to a update from you! 

Level 3

Hey, I tryed once and it didn't work, but i'd like to retry once again when as soon as I'll have spare free time, I'll come back to you in a couple of days.


Thanks for reaching back out and providing that update. If doing that one more time doesn't do the trick, we'll like for you to go to our support website. Our support team will be better equipped to figuring out what else could be causing this. 


We might need to take a look at your Logs, to gather your Logs please do the following.


  1. Please connect your Oculus device to your computer
  2. Find your Oculus installation directory (Generally this will be located at 'C:\Program Files\Oculus')
  3. Navigate to Support and then oculus-diagnostics
  4. Double-click OculusLogGatherer and wait for an executable to appear
  5. Select Get All Logs
  6. This will create a .zip file on your desktop. Please attach that zip file to your reply

Now once you get your Logs, please do not send them here. We don't have the necessary tools to look at them through here. 


Once you get to our support website, a agent of ours will be more than happy to take a look at them and see what could be causing this. 


We wish you the best and have a wonderful day. 

Level 2

I'm having this exact same issue but VR video won't play in headset browser either.

Hello, Jared. We are astonished to learn that your headset has audio but no display, and we are even more upset to learn that your web browser is malfunctioning, so please bear with us as we investigate this further.


  1. How long have you been having trouble with this issue?
  2. Please send us a picture of the screen.

Level 2

I'm having identical problems not being able to see VR capable videos in Chrome.  I also am stuck on the loading screen as pictured above, my screen is identical.  I'm pretty sure the last PC update has caused this because I had no problems previous to the update.  I have tried the recommended fixes with no success.