Showing results for 
Search instead for 
Did you mean: 

Problems pairing RMA Quest 2 to Mobile App - Solved - YOU MUST READ THIS.

Level 5

I had to send my Quest 2 back to Meta as the battery was failing to hold charge and dropping. 

I received a refurbished RMA Quest 2 very promptly. 

The problems are that when powering up, it prompts for a code and then whilst the app on the phone (Android or iPhone) detects the handset, the unit wont pair. 


This fix is NOT a workaround - it is due to the fact that older version of the firmware V42 was loaded onto replacement headsets that are being sent out as refurbished.

Oculus Support posted this on threads, but Meta/Oculus already approved these steps

This can void your warranty and brick your headset if done improperly. If you choose to do so, at your own discretion, we can't really stop you. Just be wary and keep in mind the possible repercussions. 
Additional information:
Whilst Oculus Support has posted the above message - good advice - my post below is a copy of the original post that was approved by Oculus/Meta support but has been made more user friendly to users who feel a bit apprehensive about doing this, I have posted that original link here as proof. of the original steps.
Solved: Re: Can't set up RMA'd Quest 2. Doesn't detect con... - Page 2 - Oculus Community - 983361 (...
If the firmware load is no good the recovery system will simply not write it to ROM flash memory.

The more Kudo's this message gets assists me knowing how many have succesfully upgraded their Quest 2.

I have now upgraded my Quest 2 to V46 using the Apple MAC (not iPhones or iPads), these instructions are being edited to try and make clearer due to the directory structure on a MAC, if you need these, let me know, it worked perfectly.


The V46 firmware is also available to download, I can supply if needed, but you must upgrade to V43 and then V44 through the headset first!

This solution will work on PC computer (Windows).
For mobile devices please see the reference to a forum in FB near the bottom of this message, where I have posted the name of a technical group which has just been set up, they can probably help with directing you to a video to try and connect the headset to a mobile handset or iPad.

I can confirm (after chatting to someone in the know!) that when the RMA headsets are shipped, the code (firmware) is V42, (version 42).  - Meta have upgraded their new units (or stock units) to V44 (version 44).
The mobile apps are also now only communicating to V43/V44 devices, so therefore receiving a V42 RMA refurbished unit will NOT (NEVER) connect to the V44 mobile app. 

You need access to a PC (Computer), and download the relevant applications, there is no "install" on the PC, the two links below just download the two zip files.
First: Rename the file from step 1 to the name (make sure you have Windows Files Extensions enabled so you can see the .ZIP extension)
Second: Download the Android Debugger Bridge from step 5 on your PC to allow it to communicate the Headset. 
You do NOT need to do anything with your mobile phone or try and link this to the PC Computer.
All you need is to downloaded the ZIP files for the Android Debugger Bridge so don't follow any instructions on trying to link your phone to your PC.
Just download the correct ZIP file for your PC Windows Version once done follow the numbered steps below.
You need a full USB-A to USB-C cable.
You can also use the cable supplied with the Quest 2, or if you don't have it you can buy a good quality USB-A to USB-C cable from most online retailers fairly cheaply!

I followed all the steps below myself in 15mins and my Quest 2 is now fine. 
I have re-sorted the steps to make it flow better 
You need to do the following steps:


  1. Download the latest firmware file

  2. The above is V43, but it will update from this.
  3. Rename it
  4. Power off your Quest 2

  5. Download the Android Debug Bridge (adb) 

  6. Make a folder on the PC (something like Quest2) then move the Android Debug Bridge to the newly created folder. Navigate to the new folder.
    Unzip the Android Debug Bridge, it will probably create a folder with the same names, located the file in the unzipped folders called adb.exe, this is the folder you will use going forward to put the in from step 3.
  7. Move the file to the same folder as adb.exe program on PC.
  8. Connect your Q2 to your PC via the USB-C cable. Use the cable which came with the Q2 if possible
  9. On the Quest 2, Hold Volume - and power until the device boots into a bootloader screen
  10. Using the Volume buttons, navigate to "Sideload Update" and then press power.

  11. In the PC folder with adb.exe, open up a Command Prompt in the same directory as this adb.exe program - This can be done by holding Shift and right-clicking within the folder then click the “Open command window here” option.  (or might be open Powershell Window here), when the panel opens, a prompt will be  displayed (this is the Command Window), your Quest 2 will be connected in Sideload mode..
  12. On your PC type - on the PC you need the .\ 
    .\adb devices, you should see something like 
    List of devices attached: 123456789 sideload
  13. Under the list of Devices should be your Quest 2.
  14. On your PC type - on the PC you need the .\ 
    .\adb sideload
  15. After a few minutes the file will have transferred and your Q2 will begin updating

  16. Once updated, you should be able to pair the app with the headset

Once it has updated, you need to try and add it under the mobile app, using Devices in your app account, then "+" to add new device, pick Quest 2, then try and let it pair, it will show the code and then key that in the app, if it fails, don't try again, back out the "Try Again", touch the image of the headset in the top section, use the back < arrow to go back to Devices, pick the Quest 2 go forward to prompt for the code (amended CK 4th Oct 2022).
It might respond on the app its Paired or it might reboot and update again, it might even show the code prompt for a while, but the app should show Paired. It will probably update in the app with the serial number.
Once done, add the controllers, (in the app using the Add left and Add Right) and it will probably run through the video intro then reboot again. Once done the code message will vanish.
If you get any problems - I am based in the UK - drop me a message or we can sort out a time and maybe do a Zoom session.
Mobile Devices connection to the headset
I do not know how to use an Android or Apple iPhone to Quest 2, but from what I understand a normal USB cable will not work, and has to be an OTG cable. (not sure about Apple for OTG)  - I can't help with these requests as i don't have a OTG cable and also don't know enough about interfacing a smartphone to a headset.  I would suggest checking a new forum in FB Called : Oculus/Meta Quest 2 Repair and Technical.

Meta / Oculus support are saying this is a Emerging problem, but its the firmware on the unit on V42 that is the issue, and it should be upgraded by them before shipping and I suspect its been missed.


Credit to TerenceEden (See the original link at the top of this post) for his original approved forum message and his numbered steps,
My post is just reposting them again and i have added additional user help steps to make the process flow better for users who are a bit unsure about the process and need more explanatory instructions, and based on my own experience on upgrading my own headset.







Accepted Solutions

Meta Quest Support
Meta Quest Support

As happy as we are to know that users have found a workaround. We do not recommend this as this can void your warranty. 


We can't really stop you if you choose to do so, but please do so at your own discretion. 

View solution in original post

Why would this void the warranty?
1) A failed ADB push the recovery system will not flash this.
2) A corrupt download recovery will not flash this.

The signature and push must be valid.  This is a locked bootloader. Failed signature and it's a no go.

So I ask again why?  It's near impossible to brick the device with a ADB push of firmware.

View solution in original post

Level 2

This worked great.  thanks for the help.

View solution in original post

Level 3

THANK you so much for your help.  So far so good, everything is downloaded just need to try it out later.


View solution in original post


Bravo. Now we just need Meta to formalize the process for everyones benefit.

What about people who don't have access to a PC? 

Level 5

There is a good FB group called Oculus/Meta Quest 2 Repair and Technical, which has just started by a guy called Bob, who knows how to replace batteries and other tech stuff.
Whilst he doesnt know anything phone related (Except iPhone) I think he might be able to point users in the direction of the video that may assist, but its outside my knowledge too for pairing with a phone to the headset. 
Since the zip files don't "use any installers" and just need unzipping on a PC with a USB socket, if you have a friend or mate who has a computer then they may be able to to set up the relevant files there and then you can connect the headset to their PC.   
Do you not know anyone with a PC as a friend you can ask help from - any old laptop will probably do, I cant believe they are shipping refurbished units with old code (not updated) and stating it is an emerging problem. 
This post would be good to be "pinned" so its easy for others to locate quickly.

Level 3

O wow Chris I'm sooooo thankful for finding this article. Ur a genius! So if I don't have a PC I'm screwed!? And that's on meta!? What should I do? I've been waiting 5 weeks and all meta says is we are working on it. I have tried everything possible between android phone and the RMA headset including downloading debugging apps for my android Motorola stylus. But not sure what to do at that point. So there is no way to upgrade the firmware without a PC? I think I need to make a call to meta right now! Thank you again for this article 

John merlo

Your best bet is to try and get hold of a friend with a personal computer and get them to follow the instructions above - this route will be much faster and no messing about trying to get it upgraded by a return or trying to get a phone to connect.
Remember the two downloaded zip files just need a folder to be created and expanded into those directories in their PC. So if you can find a friend who can help with a computer, the whole upgrade process will take 20 minutes,  once the upgrade is done they can just delete those folders.

The only other way that I can see Meta actually being able to sort your problem without the computer or for mobile users who don’t want to try this themselves is to get your unit returned back to them to be upgraded with the software and then return it back again, this is why are friends will be invaluable!

There is a way to do it through a phone, but unfortunately I don’t have the knowledge, but if you check the forum above that I have mentioned on Facebook, a very knowledgeable person in there can point you in the direction of a video clip that might help you, but I think you need a special cable.

Level 2

Sorry for the noob question here Chris but what do you mean by the following?
"if it fails, don't try again, but go back one step and go forward."

Are you referring to going one step back in the setup by pushing the back button in the top left or the back button for android? When I hit the back button for android it just asks for the code again.

Sorry I will edit my instructions. I mean if it fails to pair and you get the usual message at the bottom on the app don’t retry again on the app but go to the picture of the image of the top with the headpiece use the left arrow on the app to go back to the previous screen and then go forward again to add the device so it comes back and prompts for the code.

do you need a zoom? 

Level 2

Excellent, let me give that a try and get back to you, thanks for the offer of further help, will definitely reach out if I still have an issue.

Level 4

Great post and instructions.  Fortunately I  purchased my headset last year but ran into issues when upgrading to v44 and creating a Meta account.   After a week of Oculus not working I eventually have it working.


I’m guessing my headset had v43…….