cancel
Showing results for 
Search instead for 
Did you mean: 

Put an App into VR causes stuttering

arcistar
Protege

Recently, I've noticed that if I insert an app or a browser window into Oculus, it causes stuttering. I noticed this during streaming, where I had Twitch chat open while streaming iRacing at 120hz, and immediately I would lose smoothness (it also happens offline), and simply removing the app, browser, and/or extension within the headset would restore maximum fluidity. To work around the issue, I had to use a bot to read the chat for me. However, I remember not having this problem until a few months ago. Any attempt I've made to fix the problem has been unsuccessful. Does exist a way to solve this problem? Thanks!

 

My PC specs:

CPU: AMD Ryzen 7 5800X3D

MB: MSI B550 Gaming Plus

RAM: Corsair Vengeance LPX DDR4 2x16 (32 GB) 3600 MHz

VGA: Sapphire Nitro+ AMD RX 7800 XT

PSU: Sharkoon WPM Gold Zero 750W

VR: Meta Quest 2

Audio: Creative Sound BlasterX AE-5 Plus

OS: Windows 11 Pro 23H2

5 REPLIES 5

MetaQuestSupport
Community Manager
Community Manager

Hey there, @arcistar. We definitely want you to be able to enjoy your PCVR experience, especially toggling through different apps, so we'd love to take a further look into the current performance issues. 

To pick up where your details left off, we would like to take a further look into our software, and your PC, by gathering the following: 

  • Make sure all PCVR requirements are fully up-to-date
  • Is this issue seen when using other apps found within the Meta Quest Store?
  • Has the PC software been repaired? This can help if there are any corrupted files, so if not, we can do so by:
    1. Download and run the Oculus Installation Software 
    2. You will see a screen which says "Already Installed".
    3. Click the "Repair" option, and confirm again on the next screen.

Once tested, do let us know how things continue to appear! We want to get to the bottom of this! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello, thanks for answer

I've repaired the Oculus App, but unfortunately this is not solve the problem.

About PCVR requirements, them are up-to-date. The Quest 2 is connected on my PC only through original Oculus Link Cable.

Hi @arcistar! We appreciate the troubleshooting steps that you have taken and we understand they did not work out. The next steps we would be:

 

  1. Disconnect the Rift/Link cable from the computer
  2. Disconnect your computer from the internet
  3. Backup any necessary content
  4. Reboot into Safe Mode
  5. Uninstall the Oculus PC app using the Control Panel
  6. Delete all Oculus folders from the following folder:
    • C:\Program Files
  7. Remove any Oculus folders from the following locations:
    • C:\Users\YourUserProfile\AppData
    • C:\Users\YourUserProfile\AppData\Local
    • C:\Users\YourUserProfile\AppData\LocalLow
    • C:\Users\YourUserProfile\AppData\Roaming
    • C:\OculusSetup-DownloadCache
    • Note: The AppData folder is usually hidden. Use these steps to access AppData.
      1. Press Windows key + R to launch the Run dialog window.
      2. Type %AppData% in the Run box and click OK or press Enter
      3. File Explorer will launch to the AppData\Roaming subfolder.
      4. Click AppData in the File Explorer address bar to show all three subfolders in the AppData location.
  8. Restart your computer in normal mode
  9. Reconnect your computer to the internet
  10. Install the Oculus PC app again using the setup tool from our website here
  11. Reconnect the Rift/Link cable and re-test the headset

 

We appreciate your time and patience as we work through this, hope this helps!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey @arcistar! We are reaching out again to see if you still need assistance. If you have any questions or concerns, please let us know.

 

We value your response and look forward to hearing back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

arcistar
Protege

I tried the step you wrote to me, but unfortunately it didn't work. In the meantime, I made other attempts and noticed that the stuttering only occurs when the Quest 2 is set to 120Hz. If I set it to 90Hz, the problem doesn't occur, but the decrease in fluidity due to a lower refresh rate is noticeable, so the game isn't worth it, as the speed effect at 120Hz is significantly remarkable. I also tried using the OpenXR API, but the situation remains unchanged. I wanted to try using the H265 codec as well, but the headset becomes unusable. I wonder if there will be support for the AV1 codec on the Quest 2 in the future. However, since the problem only occurs if the refresh rate is set to 120Hz, are there any other solutions I could try?

Thanks a lot!

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?