cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2, 3 & Pro - Connectivity Issues

Gunstar_Tony
Explorer

Hi everyone;

 

I have a Quest 3 and cannot connect the the wifi (it's a freebox, french internet provider).

Steps i took to troubleshoot : 

1 - I did manage to connect the quest to my cellphone via hotspot.

2 - I factory reseted the quest and retried to connect to the freebox via passwords and QR code.

3 - I trued to connect the quest via the phone app.

4 - Rooter was rebooted, i was in the same room etc.

5 - We have all other devices connecting without problem to this rooter.

 

Thanks for your help

Tony_

 

 

 

310 REPLIES 310

I work in IT, and usually, my job is to find errors and eliminate their causes.

The problem appeared with the v64 update, not the PTC, just the regular one. I never had drops before.

It's not only AirLink/PC Connection, and it's not the 6GHz only. Because I only have the 5GHz network.

It also occurs on the home screen or in any native Quest app, even if there is no connection to the PC. And that makes the Quest 3 unusable.

Channel selection doesn't solve the problem either. No other device on the network loses the WiFi connection. The router is in the same room as the Quest 3. I did complete resets of the router and re-initialization of the entire WLAN network. In tests, even the PC was shut off.

The only device that keeps losing connection is the Quest 3. The time depends. The first time sometimes after about 30 minutes or 10 minutes, and it reconnects in 2 seconds. Subsequently, it loses connection every 10 minutes (approximately), and that's the strange thing. It's not like losing connection after 13/18/3/8 minutes (whatever); it's more like a timer with these 10 minutes.

Fritz!Box 7530. WiFi 5 GHz AC+N (no AX). Mobile app version 262.0.0.2.109.

The PC settings are not important because the drops happen with and without AirLink or connection to the PC. But here they are:

PC:
Meta Quest Link App Version 64.0.0.489.367 (64.0.0.489.367).
Windows 10,
i7-12700KF, Nvidia 3080RTX, 64 GB.
But also using VirtualDesktop, same result. Connection drops.
I also did a test with the MoonPlayer and their PC app yesterday, same result. Connection drops. Player in the Quest3 resets.

As I said: It's not the PC side.
And the logs on my router say it's the Quest 3 that logs out of the WLAN and reconnects 2 seconds later.

It's like Airplane Mode on a mobile that gets turned on/off quickly.

Exactly the same, not using with pc, no problems with any other device. I am three feet from my router and it gets a signal all around my house and garden? Why when there is a fault it must be every other item you own and not the one with the fault, which was not present before the update? You dont need build numbers speed etc, all you need to know is it on the latest update and all my other items work perfectly with no wifi drops!

If something was changed during the update please just revert it back!!

 

My wifi drops in both 5 Gb and 2.4Gb at least since V64. I´m in V65 and the issue is the same.

@TheLegend27 Thanks for the update, it's good to hear that the issue has been confirmed by the Team. Hope a fix comes soon so I can use my 6ghz network as I have done for the past 6 months. Pity I had to do a factory reset as part of troubleshooting when I could have just waited for the fix.

All of a sudden two weeks ago my Quest 2 stopped connecting to Wifi. My router is an RT-AX86U. The firmware is up to date.

When I try to connect it says IP configuration error. I have tried my 2.4 and my 5GHz networks. And I tried combining them. I rebooted my modem and my router, and the Quest 2, several times. It just won't connect. All the other wifi devices on my network continue to work normally. It's just this Quest 2 that is having problems.

I went through official Web support and did the RouteThis Helps for it.  They had me do a factory reset of the Quest 2, and it still wouldn't connect.  They told me it's broken and I'll have to get a new one.  Then I took the Quest 2 into work and from my office it connected to THAT wifi, but when I brought it home and tried it all again, it still won't connect at home. I don't see any settings in the router that would have blocked this. I'm the only person in the house with the credentials to fool with it, and I haven't even logged into it in months anyway.

My next step after this would be to do a factory reset of the router... Before I do that (with all the disruptions it will cause), I wanted to ask here if anyone can help with any ideas.

Been having constant WiFi disconnection issues since I got the headset over a year ago, however since the last update it seems to be happening about four times more often. I had five (!) WiFi disconnections during last night's VRChat meet (streaming SteamVR via Virtual Desktop) over a three hour period, which is the worst that it has ever been. It also disconnected a moment ago while playing Pavlov Shack (Quest native title). Upon the network recovering, both controllers also lost their connection to the headset and did not recover until the app was closed.

It's impossible to recommend the Quest Pro to anyone. It's a fun novelty and the face and eye tracking features are excellent, but the headset is far too unreliable. My Quest 2, Quest 1 and Pico 4 have never had issues maintaining a solid WiFi connection on my home network, but the Quest Pro has always had problems from day one. I've discussed the matter with several friends who are also Quest Pro users and they've experienced similar issues. Would be wonderful if these problems could be resolved once and for all.

@Alopexus  Since V64 non-ptc update I have noticed a few WiFi disconnects using Air Link with both my QPro and Q3.  I never actually have had these before this.  A few others have also noticed this issue.  I have filed a bug report and I suggest you do the same.  Hopefully this will get fixed with the next update, V65.

Edit; No problems with Link at least.  It continues to work very well and I’m tending to use it more often for now.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

blackboxy
Explorer

I have the same problem, the Q3 disconnects the WIFI randomly on 5 Ghz and 2.4 Ghz.

There must be a bug in v64.

Since my post got rolled into this one, as an update to the questions above:

 

1.  Comcast

2/3. I'm using my own router.  An Asus RT-AX86U

4. Standalone, not mesh

5/6.  I don't use the guest network.  I do have separate network names for 2.4 and 5GHz.  I did try enabling a guest network and connecting to that, no luck.  I did try combining the 2.4 and 5 and connecting to THAT, no luck.

7. I was using the virtual keyboard.

8. I configured the router myself using the desktop web page.  I also do use the app.

I would file a bug report, but it would go nowhere.

  1. What's the full version number of your headset? - 64.0.0.508.370.586682934
  2. What version is your mobile Meta Quest app running? - 264.0.0.6.109
  3. What's the full version number of your PC app? - 64.0.0.489.367
  4. Any potential workarounds? - Currently using 5GHz instead of 6GHz for streaming, but I prefer 6GHz.
  5. Which router are you using? - TP-Link XE75 Deco Wifi 6E router
  6. What are your PC specs? 14900k, 32GB ram, RTX4090, Win11
  7. What troubleshooting have you tried already?
    - resetting router
    -updating all firmware (headset, PC drivers, router firmware is latest)
    -testing 6GHz on another device (steam deck), no issues with the steam deck. Able to get a stable 1300 megabits in a LAN speed test with the steam deck, no connection drops
    -deleting all other access points on the quest, readding the 6GHz access point
    -changing router channels with the channel optimizer
    -Testing 5GHz 160MHz wide wifi6 on the quest 3, this is stable on the firmware version above, whereas 6GHz 160MHz wide wifi 6E refuses to stay connected when any heavier traffic starts on the device (namely PCVR streaming)

Replying because I am experiencing complete connection instability on a TP-Link XE75 used as a wifi 6E (6GHz) access point on my network, connected via 2.5GB ethernet to my PC, after updating to v64. The headset can find and connect to the 6GHz network, and stay connected for a little bit (a few minutes) with minor instability (disconnect/reconnect) when there is little network traffic. Disconnects happen frequently and nearly instantly (within a few seconds) when PCVR streaming starts. Wifi 6 (5GHz) is stable. The router is line of sight with my device.

I used 6GHz a little bit in v63 firmware and it seemed stable from my experience, but I haven't had the headset long and don't have a way to go back to v63 to confirm.

I am on the stable v64 firmware, not the PTC firmware.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?