cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 + Laptop: 3 dots when using Link

Aussywoo
Explorer

I would like to begin by saying I am very aware of the most common solutions to this problem (in fact, I have posts dating back to 2020 on this subject matter solving the issue).

I'm running into a similar problem with no working solution at the moment. When I start up Link, I get the permanent 3 dots loading screen with audio coming through properly. I am almost 100% this is an iGPU dGPU issue because of the following symptoms:

  • When I disable my iGPU, I can successfully load into link. However, this comes with several issues including 3rd party VR apps not working (like Space Calibrator for full body tracking). More importantly, framerates seem to be fine until I load into ANY steamVR game at all. Then I get a strange reading where Steam is telling me my frametimes are less than 2 milliseconds but shows a red graph while my headset and FPSVR tell me I'm running at 10 -- which is completely unplayable.
  • If I try using Oculus Killer (only for experimentation), Link immediately loads directly into SteamVR (skipping the Oculus dashboard completely) with smooth visuals. This runs fine for about 5 minutes before the headset freezes up (however my desktop will still show the game running fine).

Here's my setup:

  • HP Omen 15 Laptop (Ryzen 5 4600h, GTX 1660 Ti, 16gb RAM)
    • All are on latest drivers/BIOS
  • Oculus PC Software - On latest version as of September 9th, 2023
  • Oculus Quest 2 - On latest version as of September 9th, 2023

Here's what I've tried:

  • Windows Graphics Settings: Telling all the Oculus executables to use my 1660Ti
  • Nvidia Control Panel: Telling all the Oculus executables to use my 1660Ti
  • Rolling back my GPU drivers back to February 2021. This solution worked as long as I had my windows graphics settings telling Oculus executables to use my dGPU. Unfortunately, this solution stopped working sometime earlier this year as the Oculus app began requiring GPU driver updates in order to even load into the app.
  • Disabling my iGPU (however, I described the problem I've been having above).

To summarize, I originally solved this issue by keeping my old GPU drivers + making sure the Windows Graphics Settings were telling Oculus to use the hardware. However, this solution no longer works as the application requires the most up to date GPU drivers.

Any ideas?

Aus

 

5 REPLIES 5

MetaQuestSupport
Community Manager
Community Manager

Howdy @Aussywoo! It appears you're getting 3 dots when you use Oculus Link. It would be awesome to have you in PCVR, so you can enjoy your experience fully. I'd like to provide a few details to ensure we're as efficient as possible. Please continue with the following:

  • Make sure you're using the latest "game ready" drivers.
  • Please try the official Oculus app, rather than a third party app from Steam and see if performance issues remain.
  • If possible, try using another PC

 

Feel free to reach out to us at your earliest convenience! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

MetaQuestSupport
Community Manager
Community Manager

Hey there, @Aussywoo! We were just checking in with you to see if you were still needing assistance. We look forward to hearing from you, and want to ensure you're well taken care of. We hope you have a great day!
 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you for replying. I already tried the three things mentioned in your initial reply before making this post. The only notable piece is that my desktop (my laptop is the one having issues) works fine with Oculus Link.

I've already found a solution using Virtual Desktop to circumvent these issues. Virtual Desktop has no problem loading into my laptop with my GTX 1660ti. My suspicion is that something between my PC's configuration and Oculus driver allows for Oculus Link to consistently ignore my dGPU. As previously mentioned, in my laptop's normal configuration (with Windows Graphics correctly telling Oculus to use my dGPU), I can't even get Link to load up at all. However, using Oculus Killer (which skips the Oculus Dashboard completely) proves successful as SteamVR has no trouble displaying to my headset. Once again, I only used Oculus Killer to experiment and try to pinpoint the issue. All signs point to an issue with Oculus Link having trouble identifying which GPU to use in my PC.

Aus

Glad you were able to find a workaround!! I've seen a couple posts where other users are having similar troubles (such as this thread), and I know the engineering team is actively looking into getting any bugs straightened out with Link. Just to clarify - are you using Air Link, or a cable?

Through the darkness of futures past, the magician longs to see. One chants out between two worlds: Fire... walk with me

In my case, I have tried using both with the same problems. Outside of troubleshooting, I do generally only use the cable otherwise though.

The only things that got Link to display to my headset at all were:

  • Disabling my iGPU (although this led to other issues like I mentioned)
  • Using Oculus Killer to skip using Oculus Dash and loading straight into SteamVR
  • Previously: Keeping my 1660ti driver rolled back to early 2021 versions (this solution stopped working somewhat recently this year where the Oculus app would force me to update). I have a forum post detailing this issue on my account here.

Hope this helps!

Aus

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?