cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 Link Cable freezing

aqueous.chromosomes
Honored Guest

I'll just mention before anything else that I have already scoured through all previously mentioned advice on how to solve this issue to no avail and at this point I am stuck. I *know* that I have the right equipment to run SteamVR smoothly and I *know* that Meta Quest has *zero* issue connecting to it via Link Cable because all of it just worked... until recently. 

Recently Ive been having issues where Quest 2 Link Cable would freeze after 30 minutes of gameplay using SteamVR and would have to disconnect and reconnect Link multiple times before getting a stable connection (which will last for 10-15 minutes before doing this dance again). In between the disconnect/reconnect sessions, Quest Link would freeze almost immediately after loading. Mind you, nothing on the PC side is broken. SteamVR is still running, Meta Quest still recognized the device as connected, and the game exe is still launched and running. It's just that for whatever reason, the Link Cable connection keeps freezing again and again. 

And like I've stated, I've already ran through several previously mentioned advice on how to fix this issue. Here's just some but not all of the things I've tried to ensure Meta Quest runs correctly:

-ensure the graphics settings are set to default and that the options on Oculus debug tool are set to their default configurations

-set my computer power option for high performance

-turning off USB power savings on all available USB

-swap between different USB cables and USB ports, ensuring that I am connecting directly to the motherboard 

-repair the Meta Quest Software, then procceding to uninstall while in safe mode and reinstall it again

-make Meta Quest run in Realtime priority in Task Manager

-update all my drivers 

At this point I have just about had it and I am contemplating about swapping to a different VR platform, one more suited for PC gaming. I am growing impatient with the amount of hoops I needed to go through to get it to play nice on PC (don't get me started on how abysmal it ran on AMD graphics, that a different topic all together.)

 

Specs:

Nvidia GeForce RTX 4080 super

AMD Ryzen 7 7800X3D

32 gb DDR5 Ram

Gigabyte B530 Motherboard 

Windows 11 Home 

11 REPLIES 11

MetaQuestSupport
Community Manager
Community Manager

Hello there, @aqueous.chromosomes! Thank you for reaching out and bringing this to our attention. We understand how having your Meta Quest 2 Link cable freeze after 30 minutes into a game can really disrupt an amazing VR experience, so we would be more than happy to take a closer look into this for you in order to get you back to a smooth VR experience. In order for us to get a better understanding of this, we would like for you to try and answer the questions listed below. 

 

  • Does Meta Quest 2 work via Air Link? 
  • Does the Link cable work better on a different PC? 
  • Are you using an official link cable? 

And can you let us know if you are having issues with non-SteamVR when playing Meta Quest games? We would like for you to try and answer the following. That way, we can know what course of action is best for us to take next. We look forward to hearing back from you soon! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

1. Yes but it's laggy due to poor wifi signal hence the need for link cable. I am not interested in air link, only fixing cabled link 

2. It did work fine on another gaming PC (though I don't have access to that computer at the moment to compare/contrast)

3. Yes it is an official link cable

I don't have any other games through Meta, I exclusively use it for SteamVR. Which I wanna emphasize was working fine and well. And SteamVR when I am just in in their own Home Instance is fine. It's only when running something like VRChat that I am getting this issue. (Which once again I wanna emphasize that the PC side of things is working fine and Meta Quest on PC still says it's connected when frozen)

Thank you for confirming with us. We'd love to get to the root of this for you if you can please test out Meta games and apps to see how it goes once again. It's just for testing to see how that goes. We can't wait to hear back from you soon! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @aqueous.chromosomes!

 

We're just circling around to see if you need any more assistance from us. If so, please feel free to hit us up again regarding your issue. If not, don't be afraid to reach out to us with any questions, concerns, or issues.

 

We hope to hear back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi so I tried following your advice and here's what happened. 

Downloading standalone software I can run just fine. No interruptions found 

 

However, when using meta quest software via Link caused the same issue as noted above. 

Thank you for clarifying that for us @aqueous.chromosomes! We wanted to confirm if this issue is occurring with all apps or just VRChat. Additionally, have you tried using multiple Link Cables? We also have a few more things we wanted to suggest or ask about:

  • Do you have many programs open? Try closing everything you can except the required programs to use VR, including background programs such as GeForce Experience, Discord, other game launchers, hardware programs for your mouse and/or keyboard, or any other any non essential programs.
  • We also recommend you try removing all USBs except the required ones (Keyboard, Mouse, Link cable)
  • You mentioned that the PC is still running when the freezes happen. Are you still able to hear sounds from the headset when the connection is frozen?

We have a few more tricks we would like you to try, so let us know if anything changes with these ones and we would be happy to review things further. Feel free to reach out to us directly by sending us a message from our Profile Page. We look forward to hearing back from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Oh yeah with something more intense like Half Life: Alyx I can barely get through the main menu before link starts freezing and disconnecting. I've tried going between an official link cable and a third party one and both are having same issues. (Although the third party one seems to last a bit longer)

I actually have already tried closing all other programs under for VR and have the PC focus solely on running Meta Quest, SteamVR, and whatever I'm running at the moment (VRChat, Alyx, etc). 

 

The only things I've ever plugged into my computer USB when running is the Meta Quest, keyboard and mouse, and monitor (which is plugged directly into the GPU instead).

PC side, everything runs well, still shows that Quest is connected. However no sounds or controlling rumble is present. Is is that kind of frozen screen where if you turn even slightly away from what you were looking at, it's all black and distorted lines. 

I can only suspect one of two things. Either both cables are bad or the USB C port is bad. I'm going to try getting a brand new cable to make one final diagnostic sweep. 

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?