cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 Link stuttering and Link Details showing dropped frames, PC is not struggling

Hey all, I recently bought a Quest 2 to use primarily with PCVR over wired link. It's been having this issue the entire time I've had it. I've been seeing dropped frames and visible stutters. The GPU is NOT dropping frames though. Application frames dropped and compositor frames dropped in ODT both do NOT increment when it stutters. The dropped frames counter in Link Details does correspond to the visible stutter. This happens consistently all the time, regardless of game, utilization, or even just sitting idle.

 

Video of the issue:

 

I've tried everything. The issue persists with a fresh Windows install. Changing resolution/refresh rate/bitrate have zero effect, from all minimum to all maximum. I even tried a 6800xt with the exact same results. All software, drivers and BIOS are fully updated.

 

I posted about this on Reddit, and it seems that others are having the same issue, and reporting that it started with the v46 update.

 

Specs:

  • CPU: Ryzen 7 3700x

  • GPU: RTX 2070 Super

  • MB: ASUS ROG STRIX B450-F

  • RAM: 32GB (4x8) 3200

  • SSD: Samsung 970 EVO Plus 1TB

  • Windows 10

  • Link Cable:  Kiwi Design 16ft cable

Any help would be greatly appreciated. This issue is really bugging me.

30 REPLIES 30

MetaQuestSupport
Community Manager
Community Manager

Salutations! Link issues? Wow this is not the experience we want for you regarding your VR device. No problem, we want to make sure you are up and running with ease! Just to start off, it is always great to make sure you are using the Meta Link Cable for the best results! To see if your Link Cable is compatible, please click here
 

Just to make sure we are on the same page, we want to ask a few questions:

 

  1. Is your cable bent or damaged?
  2. Are you connecting their USB cable to a USB 3.0 port

We cannot completely assist you on this platform, due to the limited tools we through Forums. Which is why we will need to direct you to get support from one of our amazing agents by clicking here. We can't wait to see you back in the VR world again!

Hey there, standard troubleshooting will not resolve this issue. We are trying to bring more attention to it as we are being ignored and given basic troubleshooting as a “solution”. This encoding issue is within the oculus software. More than one of us have tried windows versions 20h1, 20h2, 21h1, 21h2, 22h2, all said builds on windows 10 AND 11 have this issue. Issue persists across link cable and air link both. Even virtual desktop is exhibiting the issue. Something went wrong with the v46 update and it ruined oculus link for many of us. This issue is extremely detrimental and makes pcvr unplayable. I have tried all nvidia drivers from 446.14 through the most updated drivers today. Nothing resolves the issue. I have clean installed windows 3 times now. No dice. You can SEE this issue happening with oculus hud enabled on encode/decode. None of the frame drops correlate with the encoding issue, therefore this is an error with the v46 update. No amount of clean installs will fix the error. Oculus repair for the app does nothing to fix it either. PTC is off on all tests, and have been tested with it on as well. This issue has been tirelessly troubleshot by many of us and the overall consensus is that the error is happening due to the newest update. Usually, there’s a workaround to make errors like this cease but there is not a single workaround this time. We need a true fix, and that’s only going to come in a future update. So instead of basic steps, could we potentially escalate this to whoever can make this known to the devs? That is the only way this type of issue is going to be fixed. There are more people speaking up about it, so it must be more widespread than people previously thought. Any assistance in bringing this to the attention of the right people would be appreciated. 

The cable is not bent or damaged. The issue occurs with all cables and over air link as well. I am using a USB 3 port. I have tried every USB port on the PC with no change. I have submitted a support ticket.

yes link issue !

 

And years   after  years it just gets  worse

and now with a 4090 everything is crumbling and I do not expect  anything from Meta 

about doing something about link-pc vr !

 

This is a link issue. Please help to fix it.

 

You can try the games below on PCVR: SteamVR

- HL Alyx

- Boneworks

- Beat Saber

 

You're in safe hands, Jeff! Our support team is top notch and has tons of access to support tools to better assist you. You'll have a fix to this issue in no time.

When can we expect a fix?

At this point I wouldn’t hold my breath. It’s all just one big runaround. Maybe they’ll have a fix in v47, though I doubt it with the responses we’ve been getting in regards to all this crap. Imagine breaking your own runtime and not issuing a fix for it or offering a way to rollback to previous versions lmao. If you break something, maybe just don’t release it 🙂 doesn’t seem too illogical, right? 

Edit: I, alongside MANY others right now, am just annoyed. Air link, cable link, the headset, resolution, tracking have all been really great…most of the time. There’s always a select few updates that introduce some form of stutter or tracking issue, but they always resolved it. For some reason, they just couldn’t care less about making a statement or acknowledging fault on this one and it’s becoming my main gripe of the year. I hope you still get to enjoy what the headset can offer you, especially with what dope 3rd party solutions like kiwi grips and Bobovr m2 plus can bring to your experience. I can’t say I have high hopes though because if I were new to the platform and this had been my first experience, I would have gotten out too. 

By the complete lack of feeling for the situation, and with weird answers in east to questions in west, I am pretty sure you/we are talking to a bot trying to redirect to 'oculus support', which apparently have some magic they can not use on this forum?!? (I guess it's the ability to create a ticket) sigh..

 

edit: typos. 😃