Showing results for 
Search instead for 
Did you mean: 

Quest 2 PCVR stutter (Alyx/Boneworks) (Link cable, AirLink, VirtualDesktop)


The problem:


Roughly every 1-2 seconds, there's a small judder/stutter in PCVR games when moving. It's almost like a previous frame is rendered again. It is very noticable in alyx and boneworks using the joystick to move left/right and looking at a static object. I assume people playing with other movement types wont notice it easily.

It does not show:

  • On steamvr frame graph
  • On any of the oculus debug tool performance overlays, performance is rock solid on all graphs.
  • On the desktop window fro boneworks/alyx
  • On the steamvr vr view

Only shows in headset.


It occurs:

  • In alyx using steamvr
  • In boneworks using steamvr
  • In boneworks from the oculus store

I have tried two PC's:


  • Intel i7 8700K
  • 16 GB 3000mhz CL14 RAM
  • Nvidia GTX 1080


  • AMD Ryzen 5800x
  • 32 GB 3600mhz CL16 RAM
  • Nvidia RTX 3070

Most testing has been done on PC#2, but the experience is exactly the same.


What I have tried:

  • Official link cable, airlink and virtual desktop
  • Factory reset headset
  • Fresh windows install with only oculus client and steamvr installed, nothing else at all
  • Disable game mode
  • Turn off super sampling in steamvr (pretty much all combinations of steamvr/oculus settings)
  • Turn off ASW in oculus debug tool
  • Turn down all settings in game and run at lowest resolution in both oculus and steamvr. This in turn ran alyx with a frametime of about 1 ms.
  • Raised priority of all combinations of involed processes (oculus server, vrserver, the game etc.)
  • Used all combinations of the common alyx launch options.
  • Disable game mode in windows
  • Set the CPU/GPU profile to level 4 via. sidequest.
  • 72hz, 80hz, 90hz, 120hz (vd)
  • More stuff I forgot probably


  • I get 2.5 gbps on the USB test
  • There is no delay using airlink or vd. VD shows no network latency spikes. I run 2.5 gbps LAN to a wifi 6 router.
  • Nvidia drivers are the newest.

I have read countless of topics complaining about steamvr/alyx/boneworks stuttering.


My first thought is:


It might be the nvidia driver thing:


However it seems like it should be solved unless you run GPU monitoring software, which a fresh windows install obvously doesn't have. Odds are that this might not be the case, but everyone with new nvidia drivers should experience it, and some people claim to have a completely smooth pcvr alyx/boneworks experience? Are they just not using smooth locomotion and not noticing it?


My second thought is:


My headset is either broken or the stutter is a software error, either with the oculus compositor/encoder or the decoder on the headset. Again here, other people should experience it.


Third thought:


It's just a general thing with quest 2 and people just don't notice it? I experience no issues at all with native headset games.


I have only had the quest 2 for a couple of months and while I've enjoyed native games (mostly beatsaber), it has been a huge dissappointment having so many issues with PCVR.


Anyone have any advice at all? I'm about at that point where I consider returning it as defective.


If you want to test it, just boot up alyx or boneworks, look at a static object fairly close to you and move left to right to left continuously (smooth locomotion). You should see a small stutter every once in a while.



Although I am also on Windows 10 I am going to try the "fix" for Windows 11 where you make sure the OVR Server is visible from the Oculus Debug Tool. Let's see if that does anything



Yeah I tried it and it didn't work lol. Every time I played the game the game window would take focus instead of the OVR terminal window. So yeah, insane stutter in literally every SteamVR game I play using the Quest 2 and it doesn't matter whether it's with wired Link, Air Link, or VD. I strongly suspect this is some kind of video encoding error or a bug in running SteamVR with the Oculus runtime. However, this stuttering is present even when running games like B&S in "Oculus" mode instead of SteamVR mode.


I tried using the Lost Frame tool to see if it would capture anything. Looks like there are lost frames despite me using Oculus Device Settings default resolution and my CPU/GPU being more than enough to play VR games at 90hz. This is from a 30 minute session of Blade and Sorcery. It's a steam game that I launched through the Oculus application on my pc desktop. Next I will capture Myst gameplay straight from the Oculus store that I also experience smooth locomotion stutter in but a perfectly smooth experience when teleporting.


lost frame toollost frame tool


I have a very low tolerance for motion sickness in VR. At the same time I'm a huge enthusiast of VR technology. So the only option for me was to build this ridiculously powerful rig, that can give me stable 90fps in all VR games I wanted to play. And I did build it and enjoyed a lot of games, especially Alyx. Today I switched from win 10 to win 11, launch Oculus overlay via Air Link and experienced this "strafe stutter", which immediately gave me a headache. After a few hours of searching through forums and testing, I have finally found a solution: "ODT->Service->Toggle console window visibility". After the restart "strafe stutter" disappeared (kudos to Advanced VR fare on YT).

I just replied above about trying out this fix for those who experience the stutter on Windows 10. This fix does not happen for those of us not on Windows 11.


As for using Windows 11, the front page explicitly states that Windows 11 is not supported for Link. You should downgrade to Windows 10 if you want Oculus to continue to support.


As for us on Windows 10 experiencing strafe stutter, I played a session today with the Oculus performance overlay and the data matched my experience: pure smooth 90hz when standing still: dropped frames when moving or even when snap turning. I have a support ticket open and submitted outputs from the Performance Profiler tool in hopes to see where in the pipeline the stutter is occurring.

I would really appreciate an update if you find any solution or get some informative response from Oculus!

Honored Guest

Just want to chime in and say I have been experiencing this problem since, gosh... 2020? Using a link cable on my Quest 2, I experience that strafe stutter on Oculus PC and SteamVR games, however games run natively on the headset itself separate from the PC run TOTALLY fine. I just bought another Link cable to see if that was the issue but nope, same old same old. Running a 3090/5950x/32gb of RAM CL16, and prior to this newer rig I'm on I've had the same thing happen to me on other computers as well -- a gaming laptop with a 3060 and an older desktop with a 2080Ti and Intel 9900k (that time, with a Rift S instead of a quest 2... literally same exact problem though). I don't understand -- games were buttery smooth before 2020! Now all of a sudden, it's stutter city no matter what hardware I'm on. Literally at a loss as to what to do. Will probably get a Reverb G2 eventually to replace my Quest 2 for PCVR because clearly Oculus doesn't care about addressing this issue. 

Hey there, thanks for bringing this to the community! We understand how frustrating this is to everyone. Let's see what we can do to get to the bottom of this. 


Oculus Link allows you to fine tune your graphics preferences via the Oculus desktop app. As a general rule, the more you crank up display options like refresh rate and render resolution, the more the overall performance of Link can be negatively impacted.


If you find that Oculus Link looks choppy (screen stuttering, frames dropping, etc) try the following:

  1. Open the Oculus app on your Computer.
  2. Click Devices on the left side of the app.
  3. Click Quest and Touch.
  4. Click Graphics Preferences.
  5. Click Reset to default.
  6. Click Save and Restart

Keep in mind, if you've previously adjusted any settings for Link with the Oculus Debug tool (including Encode Bitrate, Encode Resolution Width, Pixel Per Display), changing the graphics settings above can negatively impact your performance.


To fix this, set all numerical values you changed to '0' (zero) and then restart the Oculus Desktop app.


If you're still having trouble with Link after making the above adjustments, please contact Oculus Support

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I like your point at the end... like... maybe it is something people don't notice? I definitely notice it though and it's so annoying lol

Honored Guest

TLDR: I think Link Sharpening might be causing this stutter for some people, turning it off solved it for me.


So, I've had this same issue for quite some time, and it has been killing me with simracing; those stutters popped up recently and what was normally a fun experience quickly became... a quick barffest. I noticed that simply opening SteamVR and "strafing" at the menu would show some intermittent kind of how you described - no frame drop issues being reported but nothing ever feeling smooth and instead feeling jerky and jittery. However, I DO KNOW THIS WASN'T ALWAYS THE CASE FOR ME - it's only cropped up rather recently for me. My setup:

  • AMD Ryzen 3900x
  • 32 GB 3600mhz CL16 RAM
  • Nvidia RTX 2080 Super
  • Oculus Quest 1 connected via USB Link
  • Windows 10, latest update

 Even though I'm using an Quest V1, it was always smooth for me via USB Link until recently. I started dicking around with ODT and disabled Link Sharpening (as I remembered it was something they added recently to the headset and just happen to see it there...) and lo and behold - it's smooth again! Sure, it's not as sharp looking as with link sharpening, but man it was smooth again! This may not be the true fix for everyone, but I hope it helps someone out there.