cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 - Pro controllers firmware update stuck at 0%

MaxxChaoss
Level 3

I just got my pro controllers yesterday and spent all night trying to pair them to my quest 2. I have been getting an alert that says "Controller Firmware Update (Left 0%)(Right0%)" every five seconds. I tried restarting my headset, restarting the controllers, re-pairing them multiple times, and even factory resetting my quest 2, but the problem still remains. The controllers have a flashing purple light on them if that helps. I gave up after about 10 different attempts, and then left it overnight.

22 REPLIES 22

MetaQuestSupport
Community Manager
Community Manager

Hey MaxxChaoss! We see that you are having issues with pairing your new Pro controllers to your Quest 2. No worries, we will make sure to get you pointed in the right direction. There has been a recent update for the Quest 2 to be able to pair with the Pro controllers. We will just need you to do the following to make sure everything is up to date:

 

  • Make sure the old controllers are unpaired.
  • Press the Meta button on your right Touch controller to pull up your universal menu.
  • Hover over the clock on the left side of the universal menu. When Quick Settings appears, select it to open the Quick Settings panel.
  • Select  Settings in the top right corner.
  • Select  System, then select  Software Update from the left menu.

There should be an update if it has not updated already. If you are still having issues after trying this, we do recommend that you reach out to our support team. Just go here and follow the prompts as they pertain to your issue. Once you do this you will be connected with one of our specialists who will be able to go over more options with you.

 

DatBoyy
Level 4

No solution worked for me yet (pair/unpair, boot while controllers are in dock, factory reset, restart again and again and again) I tried everything listed here multiple times: https://communityforums.atmeta.com/t5/Get-Help/Quest-2-Quest-pro-controllers-update-stuck-at-0/m-p/1...

Also I am not really sure on which firmware version I am. It seems to make a difference if your quest is on 47 or 49 software version. Unfortunately, the 49 update is either already installed on mine, or not available for my Quest 2. I tried updating, but the Quest 2 says it's on the latest firmware.

 

Gonna wait a few days and if it doesn't work and doesn't resolve itself, I will send the controllers back to Meta. I might start looking into the Pico headsets then. It really sucks paying so much money for a device, being excited about it being shipped and then spending 5 hours in the evening googling useless solutions because it doesn't work out of the box. Really disappointing.

MaxxChaoss
Level 3

My quest 2 says I am on the latest update v47. My controllers will pair to the headset, but they will not update to the latest firmware.

DatBoyy
Level 4

Update v49 is out for a few days, but I can't get it to download on my Quest 2. v47 is latest firmware for me, no update available. Therefore I can't use the controllers at all.

This is ridiculous for a device of this price range. I will check back in this forum for a few days, but probably going to return these controllers. I've never had such a bad first experience with an electronic device in such a high price range. If customers pay $300/350€, we should expect the device to work out of the box. I've spent 5 hours on this issue and nothing works. My first experience with these controllers is very very negative and I will remember that for a while. Going to return them in the coming days.

Hello there @DatBoyy, thank you for letting us know of your issues with the Pro controllers. We understand how troublesome this may be and we are here to help. Since you mention trying the recommended troubleshooting steps above, we highly encourage you to reach out to us from Meta Store Support so that we may look further into this for you. We hope to hear from you soon, thank you.

Four_d4
Level 4

I've been having the exact same problem. Any luck trying to fix this?

Hello there, @Four_d4! We appreciate you letting us know about your Quest Pro controllers not working properly, and we would be happy to help look into this issue! 

 

We recommend a few troubleshooting steps that will hopefully resolve this issue:

 

  1. Reboot your headset.
    1. While it is on, press and hold the power button on the right side until you see the "Power off" screen.
    2. After that, select "Restart." Your headset will turn off and then turn back on.
  2. Re-pair your controllers to your headset once again.

 

If you have done this and are still experiencing issues with your controllers, please reach out to our customer support page. Once there, we will be able to look further into this issue!

I already spoke to support and they unsurprisingly weren't helpful

Pressing the ‘meta button’ on the right touch/pro controller does nothing because they will not update therefor are not usable, not even for the ‘meta button’. 
‘What is the trick to getting the controllers to update the firmware using any other means besides the pro/touch controller? Clicking the link to ‘Just go here’ doesn’t help. Considering the controllers were bought to pair with my Quest 2 and there are no options that lead to a solution on your ‘go here’ page. It’s either a quest 2 problem or a Quest Pro problem, you don’t have a click solution for a mix of the two. You might want to update the options once a solution is found so people can actually get to it. 
‘Why is it, Meta made a simple controller firmware update more difficult than brain surgery? I just want my $300 controllers to pair with my Quest 2 so I can use my system. It really shouldn’t be this **bleep** hard to achieve. Sorry, but I’m frustrated beyond my limit right now. This wasn’t a 20$ purchase and I’m not happy at the moment. If they aren’t working in the next couple days I’ll return them and you’ll lose a sale. Yep, I get it, not a big deal to a company as big as you are Meta, but it’s a big deal to me. I’ve tried everything. I’ve been at this since 2pm yesterday. It’s 1 am now and I’m about to rip my hair out! 
‘Would be a wonderful thing if you ever put a product on the market that works out if the box without jumping through freaking hoops. 😡