cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 - Quest pro controllers update stuck at 0%

Clarity_Page
Explorer

Hi I just got my Quest Pro controllers today and paired them to my headset (Quest 2), however I can't use them and a little pop up saying "Controller update in progress (Left 0%) (Right 0%)" keeps appearing evey 30 seconds, I left the controllers a while to update but they never progress past 0%

2 ACCEPTED SOLUTIONS

Accepted Solutions

BlueberrieSmoothie
Meta Quest Support
Meta Quest Support

Hey everyone! It seems like this was an issue for quite a few users over the past week. The good news is that we've been hearing reports of Pro controllers finally updating now! If you haven't, go ahead and try again to see if your controllers are updating and working. 

If you're still getting stuck with your controllers not updating, please let us know!

Make sure you smash that Kudos button!

View solution in original post

TheAntiSocializer
Meta Quest Support
Meta Quest Support

Hey everyone! Seeing as this thread is now getting pretty old, I will be locking it. 

For any troubleshooting, I would suggest checking out our available steps here.

If you're having any issues updating your controllers afterwards, I do recommend reaching out to @MetaQuestSupport through PM or starting a new thread on our Get Help board.

Sometimes it's okay to be a little Bing Chilling

View solution in original post

307 REPLIES 307

Larry_O
Protege

I rebooted headset several times and got them to update full. Still didn't get the right one to appear so rebooted again. Just to loose the left one. A new reboot and both were showing but right one got a 30 cm offset vertically and were unusable. Not giving up, though, as the tracking is marvelous in game( Alvo) but too low right habd makes shooting a guess game 🙂

Hey there, @Larry_O! We definitely understand how inconvenient it can be when the tracking isn't working as intended, we'd be glad to help out! Here's some troubleshooting to try out and see if it helps out at all with the current issue: 
 

  • While in VR, hold the controllers at eye level, pointing in front so that the cameras on the controller can see the surroundings.
  • Move the controller around slowly for the controllers to start tracking.
  • Go through the Meta Quest app and unpair/pair the controllers.
  • Restart the controller by holding down the power button (menu) for 1 to 2 seconds.
  • Try waking them up by quickly pressing the Menu buttons.
  • Try pressing and holding the Menu button for 5 to 10 seconds.
  • If the controllers re-center, then at least the controller Bluetooth is connected. This means it’s likely the controller is not tracking.
  • Try rebooting the controller by holding down the Menu button until you see the lights change.
  • If that does not work, manually pair the controller using commands:
  • To enter pairing mode on each controller, press and hold the Menu+B (right) or Menu+Y buttons (left) for 3 seconds. You'll feel a light vibration from the front trigger when the controller transitions into pairing mode.
  • You can also try a couple of button combinations to get the controllers to appear:
  • Force power off the controllers by holding down B or Y for 15 seconds.
  • Turn them back on by short pressing the Menu or Menu buttons.

 

Let us know if this helps out at all, if not then we'll see what we should try out next. We'll be looking forward to hearing back from you! 
 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

maddievision
Honored Guest

this is happening to me too :(. everything is at full battery. tried power cycling the headset and controllers multiple times and same result.

controllers go into the pulsing purple light status and 0% progress for controller updates pop up every 10 seconds or so.

update: i unpaired and paired again and the update worked after that!

Hey @maddievision! We're so glad to see the troubleshooting steps resolved your controller issue. Happy gaming!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Would you know how to get it to update? All mine says controller update required.

We appreciate you bringing your questions about the new quest pro remotes' update procedure to our attention. To start, we can try to make sure that the headset and the application are both running the latest recent updates. Please check your Wi-Fi connection to ensure that it is operating at its best speed as well. If these are running at their optimal capacity try factory resetting the device. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

boramkiv
Honored Guest

I ran into this issue and I believe the resolution is after pairing both controllers with the quest 2, if theyre stuck on 0%, place them on the charger then restart the headset, you should see the percentage start to move. After multiple restarts, and disconnects, all it took was placing them on the charger. Make sure your headset is updated to the latest software also. 

Hello FenikkusuFl1kz, we saw that you were searching for information on how to update your Pro controllers. We are aware of how annoying this may be while trying to play with a headset and controllers.
 

  1. Can you  try charging the controllers while they are on the charger.
  2. Restarting the headset should start the updating process.

Don't hesitate to get in touch with us because we value your comments greatly.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?