Showing results for 
Search instead for 
Did you mean: 

Quest 2 Right Controller Trigger Button not working as intended


Hi , so the problem is when I press all the way down  trigger button on the right controller it doesn't register it in the vr ( it shows that I pressed it about half way in the vr home menu ) . This creates problems for various games as it doesn't allow me to shoot in some games cause i didn't press it  all the way down ( even though I did ). Left controller is working fine. This annoys me because I have to do everything with my left hand now (  Have to click menus in games with left hand , have to shoot with my left hand etc..)


Everything else with right controller is working good ( tracking , all the other buttons )

I have tried replacing the batteries but to no avail.  



So guys I have finally fixed it! I had a hardware problem with controller and since my quest 2 is out of warranty I tried to fix it myself.


Before you go, please check if your warranty is still valid, if it is just replace the controller in their store.

I've managed to fix my issue with right trigger by tinkering with the magnet a bit and placing it in the right place! Now instead of the 0.60 it goes up to 0.90 when I press it and now all my games  register click when I press the right trigger.


Quick note:  You can check if its problem with the magnet when you download Oculus Monitor app from Kojack, press and hold trigger button and move your controller up and down, if the values for the trigger change , then magnet is moving inside your controller and that's not ok , it should be hold firm in place.


The magnet that I'm talking about measures how hard you press your trigger button so if it's moving around in your controller it can't measure properly.


Honored Guest

I am having identical issues could you tell me exactly how to fix the hardware issue please ice tried everything 


Hey there! We hate to hear you're also having issues with your controller trigger button. We understand how this could hinder your gaming experience. No worries; let's see what we can do! Could you please try the following:

Let us know if this works!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there! We're just following up with you to see if you still need assistance. If so, please provide the information from our previous message and we'll assist. We hope you have a great day!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

Where is the magnet I am having your problem right now on both controllers.

Disassemble your controller till you reach step 7 ( link above ) , you can see the magnet on the picture provided in the link bellow trigger button and just glue it to the plastic that is holding it. ( assuming that it is moving around in that plastic )

Meta Quest Support
Meta Quest Support

While disassembling a controller to try and repair it may seem like a good idea, I don't recommend that that be the immediate course of action, as doing so could potentially void any warranties that you may have for your controller. We also don't know what additional damage it could do once everything is put back together.


If anyone is having trouble with their controllers not working, please feel free to reach out to our support team or send a PM to @MetaQuestSupport. From there, they will be able to see what troubleshooting and options would be available for you.

Peace is a lie, there is only passion. Through passion, I gain strength. I gain power. Through power, I gain victory. Through victory, my chains are broken. The force shall free me.

Honored Guest

I have the same Problem but only in some games like RE4 or STRIDE but not in Gorrila Tag or in the Quest menu 

Hey there, @DerNachtaktive! Having your controllers not working correctly would take away from the fun of your games, and we want to make sure you can get back to gaming without issues quickly! If you have tried the troubleshooting already provided in this thread from our support replies, please reach out over a private message so we can work with you to determine the next steps. Please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hey there, @DerNachtaktive! We received your private message, and will be right with you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?