Showing results for 
Search instead for 
Did you mean: 

Quest 2 - Software Update Required

Level 2

I have had this issue trying to pair both of my Quest 2's for the last 4 days. When you click 'try again' it just loops back to this screen.

I have tried reinstalling the app (including updating the app), using an IOS phone and using an Android phone, I have even factory reset one of the devices. Still get the below message when I try to pair this device to any phone.




Any ideas on how to fix this?




Accepted Solutions

Level 2

I have the solution 


 do this, it will manually pair your headset

View solution in original post

Retired Support

Hey y'all, Sideloading your Quest 2 is no longer necessary! There's been an update to the Meta Quest phone app that should resolve this issue. Make sure the Meta Quest app is updated to version 181.1, then factory reset your headset and try to set it up again. If you encounter any more issues after this, make sure to reach out to Support. If it works for you, give this a Kudos and let other people know! Thanks!

Genesis does what Nintendon't! Send me a DM if you have questions. I'm happy to help!

View solution in original post

Meta Quest Support
Meta Quest Support

Hey hey! Just wanted to update this thread with this solution since it seems we may have forgot to post it in here.


For anyone having this issue, please try the following:


  1. Open the Meta Quest app on your iOS or Android device. Wait about a minute while a background update is automatically applied.
  2. Close the Meta Quest app.
  3. Factory reset your headset.
  4. Try to pair your controllers and headset as new.

Note: Please be sure to check your Mobile app and Headset for the latest versions.


If that doesn't work, we suggest hitting up the team with a support ticket


Thank you! 

View solution in original post

117 REPLIES 117

Level 4

Same here 😡

Level 2

Same problem here

Level 2

Same problem

Community Manager
Community Manager

Hey everyone, thank you all for bringing this issue to our attention. 


We're currently in communication with our engineering team to get this issue nailed down, find the root cause and get this resolved. 

We'd like to encourage everyone to share their experiences and any troubleshooting steps you've tried in this thread so that we can collect this valuable information for our teams.


 We greatly appreciate the feedback, as well as your patience while we look into this!

Level 3

I’m having the same issue and so far nothing is helping. I called and they told me they were working on a repair and it should be available soon. Ug. 

Level 2

I'm having the same issue of "software update required" and it doesn't allow to go anywhere else. Are there any solutions to this issue? 

@Leo4eva Sadly not as of yet.  We suggest just holding out until there is an email sent to everyone affected with any updates,

Level 2

Adding my Oculus to the list of "Software Update Required" so I get notified of a solution...

Level 2

Same problem this is ridiculous